Re: [PATCH 2/2] Convert from K&R to ANSI

2021-12-30 Thread Samuel Thibault
Etienne Brateau, le jeu. 30 déc. 2021 12:22:49 +0100, a ecrit: > * device/dev_name.c: Convert function prototypes from K&R to ANSI. > * device/subr.c: Convert function prototypes from K&R to ANSI. Ah, somebody had previously worked on the conversion but apparently missed these, applied, thanks

Re: [PATCH 1/2] Remove name_equals and use strncmp instead

2021-12-30 Thread Samuel Thibault
Hello, Etienne Brateau, le jeu. 30 déc. 2021 12:22:48 +0100, a ecrit: > * device/dev_name.c: Replace name_equals with strncmp This is not the same, see: > - * next character of target is 0 (end of string). strncmp doesn't test that. It's important to properly catch prefixes. Samuel

Re: [PATCH] kern/thread.c: some minor style changes

2021-12-30 Thread Samuel Thibault
Adam Kandur, le jeu. 30 déc. 2021 11:26:43 +0300, a ecrit: > Greeting, I have changed some stuff in kern/thread.c which makes code > more readable for me. Maybe it will be usefull. Why not indeed, applied, thanks! > --- > kern/thread.c | 56 --- >

Re: [PATCH 1/2] Remove name_equals and use strncmp instead

2021-12-30 Thread Etienne Brateau
forget about this patch, it wasn’t intended to be sent Le jeu. 30 déc. 2021 à 12:23, Etienne Brateau a écrit : > * device/dev_name.c: Replace name_equals with strncmp > --- > device/dev_name.c | 24 ++-- > 1 file changed, 2 insertions(+), 22 deletions(-) > > diff --git a/d

[PATCH 2/2] Convert from K&R to ANSI

2021-12-30 Thread Etienne Brateau
* device/dev_name.c: Convert function prototypes from K&R to ANSI. * device/subr.c: Convert function prototypes from K&R to ANSI. --- device/dev_name.c | 10 ++ device/subrs.c| 20 ++-- 2 files changed, 8 insertions(+), 22 deletions(-) diff --git a/device/dev_name.

[PATCH 1/2] Remove name_equals and use strncmp instead

2021-12-30 Thread Etienne Brateau
* device/dev_name.c: Replace name_equals with strncmp --- device/dev_name.c | 24 ++-- 1 file changed, 2 insertions(+), 22 deletions(-) diff --git a/device/dev_name.c b/device/dev_name.c index f6133679..9f6b00f7 100644 --- a/device/dev_name.c +++ b/device/dev_name.c @@ -89,2

[PATCH] kern/thread.c: some minor style changes

2021-12-30 Thread Adam Kandur
Greeting, I have changed some stuff in kern/thread.c which makes code more readable for me. Maybe it will be usefull. --- kern/thread.c | 56 --- 1 file changed, 22 insertions(+), 34 deletions(-) diff --git a/kern/thread.c b/kern/thread.c index 903

Re: [PATCH] hurd: Implement device memory mapping

2021-12-30 Thread Joan Lledó
Hi, I attached a patch with the changes

[PATCH] hurd: Implement device memory mapping

2021-12-30 Thread Joan Lledó
From: Joan Lledó * src/hurd_pci.c: * Implement device memory mapping functions * pci_device_hurd_map_range * pci_device_hurd_unmap_range * pci_device_hurd_map_legacy * pci_device_hurd_unmap_legacy * src/x86_pci.h: * R