hadow=compatible-local]
It makes the code clearer when different variable names are used for different
purposes.
2023-09-04 Bruno Haible
crypto/{gc-rijndael,rijndael} tests: Fix some gcc -Wshadow warnings.
* tests/test-gc-rijndael.c (main): Rename local variable 'i'
* Simon Josefsson wrote on Fri, Sep 22, 2006 at 02:44:25PM CEST:
> Ralf Wildenhues <[EMAIL PROTECTED]> writes:
> > OK to apply this patch? The changes allow
> Hi! Yes, please install.
Done; I also updated the copyright year in rijndael-api-fst.c.
Thanks for the review!
Cheers,
Ralf
Ralf Wildenhues <[EMAIL PROTECTED]> writes:
> Hello Simon,
>
> OK to apply this patch? The changes allow
> gcc -g -O2 -Wall -Werror -fno-builtin
>
> to compile these files (on GNU/Linux).
Hi! Yes, please install.
/Simon
.
* rijndael-api-fst.c (rijndaelBlockDecrypt): GCC suggests
parentheses for clarity.
Index: lib/gc-gnulib.c
===
RCS file: /cvsroot/gnulib/gnulib/lib/gc-gnulib.c,v
retrieving revision 1.18
diff -u -r1.18 gc-gnulib.c
--- lib/gc-gnulib.c
I have installed the patch below. It seems the example Rijndael
implementation didn't implement CBC mode correctly...
--- rijndael-api-fst.c 14 Oct 2005 15:33:22 +0200 1.1
+++ rijndael-api-fst.c 19 Oct 2005 16:08:10 +0200
@@ -244,7 +244,7 @@
((uint32_t *) blo
mited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+
+AC_DEFUN([gl_GC_RIJNDAEL],
+[
+ AC_REQUIRE([gl_GC])
+ AC_DEFINE(GC_USE_RIJNDAEL, 1,
+[Define if you want to support RIJNDAEL through GC.])
+ if test "$ac_cv_libgcry
nt32_t?
>
> I don't know. Should I remove them?
Please do.
I suspect they were required initially,
probably because the base type was once signed.
>>> Index: lib/rijndael-alg-fst.c
>> ...
>>> +static const uint32_t Te0[256] = {
>>> + 0xc
Simon Josefsson <[EMAIL PROTECTED]> writes:
> Ok to install?
It's fine with me, yes.
___
bug-gnulib mailing list
bug-gnulib@gnu.org
http://lists.gnu.org/mailman/listinfo/bug-gnulib
Paul Eggert <[EMAIL PROTECTED]> writes:
> Simon Josefsson <[EMAIL PROTECTED]> writes:
>
>> I don't know. Should I remove them?
>
> Yes please; they contribute nothing and might lead an unwary reader
> into thinking that they're needed for some reason.
Done.
Ok to install?
Simon Josefsson <[EMAIL PROTECTED]> writes:
> I don't know. Should I remove them?
Yes please; they contribute nothing and might lead an unwary reader
into thinking that they're needed for some reason.
___
bug-gnulib mailing list
bug-gnulib@gnu.org
ht
Jim Meyering <[EMAIL PROTECTED]> writes:
> Simon Josefsson <[EMAIL PROTECTED]> wrote:
>> Revised patch.
>
> Do those `U' suffixes serve any purpose,
> given an array base type of uint32_t?
I don't know. Should I remove them?
>> Index: lib/rijndael
Simon Josefsson <[EMAIL PROTECTED]> wrote:
> Revised patch.
Do those `U' suffixes serve any purpose,
given an array base type of uint32_t?
> Index: lib/rijndael-alg-fst.c
...
> +static const uint32_t Te0[256] = {
> + 0xc66363a5U, 0xf87c7c84U, 0xee99U, 0xf67b
Jim Meyering <[EMAIL PROTECTED]> writes:
+int
+rijndaelPadEncrypt (rijndaelCipherInstance * cipher,
+ rijndaelKeyInstance * key, unsigned char *input,
+ int inputOctets, unsigned char *outBuffer)
>
> Hmm... looking at that in isolation, I wonder if `in
Simon Josefsson <[EMAIL PROTECTED]> wrote:
> Jim Meyering <[EMAIL PROTECTED]> writes:
>
>> Simon Josefsson <[EMAIL PROTECTED]> wrote:
>>> Ok to install?
>>>
>>> Comments appreciated, of course.
>>
>> Hi Simon,
>>
>> In this function,
>>
>> +rijndael_rc
>> +rijndaelMakeKey (rijndaelKeyInstance * ke
Jim Meyering <[EMAIL PROTECTED]> writes:
> Simon Josefsson <[EMAIL PROTECTED]> wrote:
>> Ok to install?
>>
>> Comments appreciated, of course.
>
> Hi Simon,
>
> In this function,
>
> +rijndael_rc
> +rijndaelMakeKey (rijndaelKeyInstance * key, rijndael_direction direction,
> + int keyL
Simon Josefsson <[EMAIL PROTECTED]> wrote:
> Ok to install?
>
> Comments appreciated, of course.
Hi Simon,
In this function,
+rijndael_rc
+rijndaelMakeKey (rijndaelKeyInstance * key, rijndael_direction direction,
+int keyLen, char *keyMaterial)
the keyMaterial parameter should b
16 matches
Mail list logo