On 9/22/20 10:03 AM, Bruno Haible wrote:
I'm not really familiar with these. Does the libgcrypt documentation help,
maybe?
Bruno
I have become much more familiar that I'd really like to be. It seems
that without the crypto/gc-pbkdf2-sha1 module defined, then
GNULIB_GC_HMAC_SHA1 is not define
Hi Bruce,
> The failing difference isn't whether or not I use gc_pbkdf2_hmac vs.
> gc_pbkdf2_sha1, the failing difference is whether or not I specify the
> crypto/gc-pbkdf2-sha1 module vs. the crypto/gc-pbkdf2 module.
I'm not really familiar with these. Does the libgcrypt documentation help,
ma
Hi Bruno, et al.,
The failing difference isn't whether or not I use gc_pbkdf2_hmac vs.
gc_pbkdf2_sha1, the failing difference is whether or not I specify the
crypto/gc-pbkdf2-sha1 module vs. the crypto/gc-pbkdf2 module. The former
works, the latter does not, with the rest of my project entirel
gnu-pw-mgr fatal error:
gc_pbkdf2_hmac returned error code 5
(5 --> GC_INVALID_HASH)
I think they work differently.
rc = gc_pbkdf2_hmac(GC_SHA1,
hash_source, hash_src_len,
salt, salt_len,
OPT_VALUE_PBKDF2,// <--
Hi Bruce,
> Next question: what do I do about crypto/gc-pbkdf2-sha1? It is labeled
> as "deprecated", but I need a function that produces precisely the same
> result. It really doesn't matter to me that folks have figured out how
> to jigger a file to produce an arbitrary sha1 sum. I only need
Paul Eggert <[EMAIL PROTECTED]> writes:
> Simon Josefsson <[EMAIL PROTECTED]> writes:
>
>> Bruno Haible <[EMAIL PROTECTED]> writes:
>>
>>> Simon Josefsson wrote:
>>>
+ l = dkLen / hLen;
+ if (dkLen % hLen)
+l++;
>>>
>>> An equivalent but faster code is:
>>>
>>> l = ((dkLe
Simon Josefsson <[EMAIL PROTECTED]> writes:
> Bruno Haible <[EMAIL PROTECTED]> writes:
>
>> Simon Josefsson wrote:
>>
>>> + l = dkLen / hLen;
>>> + if (dkLen % hLen)
>>> +l++;
>>
>> An equivalent but faster code is:
>>
>> l = ((dkLen - 1) / hLen) + 1;
>
> Perhaps for clarity we could ch
Simon Josefsson wrote:
> Perhaps for clarity we could change it into:
>
> #define CEIL_DIV(a,b) (((a) - 1) / (b)) + 1
> l = CEIL_DIV (dkLen, hLen);
>
> What do you think?
People could be tempted to borrow this formula and apply to situations where
it doesn't fit.
Normally one uses
#define CE
Bruno Haible <[EMAIL PROTECTED]> writes:
> Simon Josefsson wrote:
>
>> + l = dkLen / hLen;
>> + if (dkLen % hLen)
>> +l++;
>
> An equivalent but faster code is:
>
> l = ((dkLen - 1) / hLen) + 1;
Perhaps for clarity we could change it into:
#define CEIL_DIV(a,b) (((a) - 1) / (b)) + 1
Hi Ralf! Thanks for your comments..
Ralf Wildenhues <[EMAIL PROTECTED]> writes:
> By the way, has anyone suggested to use one of these documentation-
> from-source-comments generators for gnulib yet? Has it been rejected?
I don't think anyone has proposed it. I'm somewhat biased towards
GTK-D
Hi Simon,
* Simon Josefsson wrote on Wed, Oct 12, 2005 at 03:13:28PM CEST:
> I have installed this. Comments most welcome, as always!
Here you go.
>
*snip header with nice documentation*
By the way, has anyone suggested to use one of these documentation-
from-source-comments generators for gnu
11 matches
Mail list logo