Hi,
While preparing a new libunistring release, I noticed that gnulib-tool
brought in many more files than for the last release, in particular these:
gnulib-m4/cloexec.m4
gnulib-m4/dos.m4
gnulib-m4/fcntl.m4
gnulib-m4/getdtablesize.m4
gnulib-m4/lstat.m4
gnulib-m4/pathmax.m4
gnulib-m4/stat.m4
gnuli
The creation of a binary file from within javacomp.m4 created a wrong file
on Solaris, because Solaris 'tr' (all of /usr/bin/tr, /usr/xpg4/bin/tr,
/usr/xpg6/bin/tr) behave differently than GNU 'tr' in a particular case.
2009-12-26 Bruno Haible
javacomp: Portability fix.
* m4/j
Hi,
I wrote:
> +/* Determine the current per-thread locale's name, as specified by
> uselocale()
> + calls.
> + CATEGORY is a locale category abbreviation, as defined in ,
> + but not LC_ALL. E.g. LC_MESSAGES.
> + CATEGORYNAME is the name of CATEGORY as a string, e.g. "LC_MESSAGES".
> +
Jim Meyering wrote:
> FYI, grep is using isdir, and merely compiling it with
> gcc's -Wmissing-prototypes would provoke this:
>
> isdir.c:28: error: no previous prototype for 'isdir'
>
> so I've cleaned up:
>
>
>>From 8fedd05841d5e693cd8fb5266a7963bc075c45f6 Mon Sep 17 00:00:00 2001
> From: Jim
FYI, grep is using isdir, and merely compiling it with
gcc's -Wmissing-prototypes would provoke this:
isdir.c:28: error: no previous prototype for 'isdir'
so I've cleaned up:
>From 8fedd05841d5e693cd8fb5266a7963bc075c45f6 Mon Sep 17 00:00:00 2001
From: Jim Meyering
Date: Sat, 26 Dec 2009
Eric Blake wrote:
> Is there some other short but acceptable name? Maybe COUNTOF or
> ARRAY_COUNT? END_INDEX or LAST_INDEX?
I don't see a better name than SIZEOF:
- The terms "length", "count", "used" etc. allude to the used portion
of an array, not its allocated size.
- "cardinality" is
Eric Blake wrote:
> Here's a way to use ASSERT in a few more files. I'll probably push this
> tomorrow.
Yes, this looks good: wider applicability of the macro with minimal added
complexity.
When doing this, you can also remove the '#include ' of the files
tests/test-dirent-safer.c
tests/test