[PATCH] gettimeofday: avoid warning: nested extern declaration of 'localtime'

2009-01-18 Thread Jim Meyering
FYI, I've just pushed this: >From b4c5933136d31eeb6d8abc2301044a5a7dfe4676 Mon Sep 17 00:00:00 2001 From: Daniel P. Berrange Date: Mon, 19 Jan 2009 08:13:17 +0100 * lib/gettimeofday.c: Move extern declaration out of function. --- ChangeLog |5 + lib/gettimeofday.c |5 +++--

Re: #ifndef _GL_WCHAR_H in lib/wchar.in.h

2009-01-18 Thread Thomas Guyot-Sionnest
On 17/01/09 08:10 AM, Bruno Haible wrote: >>> $ cd gllib >>> $ cc -DHAVE_CONFIG_H -I. -I.. -I../intl -g -E getdate.c | \ >>> grep mbstate_t | head -2 >>> extern size_t rpl_wcrtomb (char *s, wchar_t wc, mbstate_t *ps); >>> typedef charmbstate_t; >> Thanks for reporting this. Ca

Re: Please do not install a charset.alias file under Mac OS X

2009-01-18 Thread Vincent Lefevre
On 2009-01-18 21:41:37 +0100, Bruno Haible wrote: > Hello Vincent, > > You brought up two different issues: > 1) The fact that config.charset for MacOS X recognizes only UTF-8 locales. > 2) The conflicts when packaging software sees a charset.alias file that >belongs to different packages. >

Re: mem*/strr*/etc... obsolete warnings

2009-01-18 Thread Mike Frysinger
On Saturday 17 January 2009 15:24:36 Bruno Haible wrote: > Mike Frysinger wrote on 2009-01-04: > > a bunch of modules were labeled as obsolete recently, but no information > > was included explaining why. > > They were marked obsolete because the problems that they fix don't occur > any more on the

Re: strftime updates

2009-01-18 Thread Bruno Haible
Jim Meyering wrote: > I suppose it's a good excuse for keeping the DO_MULTIBYTE code that > could otherwise be removed. Yes. And we never know what kinds of encodings will continue to be invented by people or governments... > Please push it. Done. Bruno

Re: strftime updates

2009-01-18 Thread Jim Meyering
Bruno Haible wrote: > How about the other small cleanups that I mentioned in > ? > Here is a proposed patch. The comment in glibc ("The GNU C Library uses UTF8 > multibyte encoding") is actually wrong, since glibc supports local

Re: strftime updates

2009-01-18 Thread Bruno Haible
Hi Jim, > > Also, the test for mempcpy is redundant since nothing uses it. Proposed > > patch: > > That looks fine, and you're welcome to apply it. Applied. How about the other small cleanups that I mentioned in ? Here is a

Re: Please do not install a charset.alias file under Mac OS X

2009-01-18 Thread Bruno Haible
Hello Vincent, You brought up two different issues: 1) The fact that config.charset for MacOS X recognizes only UTF-8 locales. 2) The conflicts when packaging software sees a charset.alias file that belongs to different packages. Ad 1) Vincent Lefevre wrote: > > You are better off filing this

Re: [PATCH] add set_shells_file function to getusershell module of gnulib

2009-01-18 Thread Bruno Haible
Hello Ben, > I find that the getusershell module is limited in which file it can > open (/etc/shells). set_shells_file is a new function that allows the > user to open a shells file that is located elsewhere. > > I've attached the patch rather than providing it inline, because I > didn't want to

[PATCH] add set_shells_file function to getusershell module of gnulib

2009-01-18 Thread Ben Asselstine
Hi, I find that the getusershell module is limited in which file it can open (/etc/shells). set_shells_file is a new function that allows the user to open a shells file that is located elsewhere. I've attached the patch rather than providing it inline, because I didn't want to gamble with gmail'

[PATCH] inttostr.c: suppress a warning

2009-01-18 Thread Jim Meyering
FYI, I've pushed this a few days ago. >From 19b4d0fb6a9dff94b74fc948880da2f0c7ddd3e9 Mon Sep 17 00:00:00 2001 From: Jim Meyering Date: Sun, 30 Nov 2008 17:36:15 +0100 Subject: [PATCH] inttostr.c: suppress a warning * lib/inttostr.c: Use #pragma GCC diagnostic ignored "-Wtype-limits" to ignore ".

Re: [PATCH] Suggestion: new module link

2009-01-18 Thread Martin Lambers
On Sun, 18. Jan 2009, 19:33:50 +0100, Bruno Haible wrote: > Your patch looks quite fine. I have applied it with this ChangeLog entry Thank you. > - Don't initialize GNULIB_UNLINK or HAVE_UNLINK - this is unrelated. Sorry, this was a leftover of an unrelated patch. > - In the module descript

Re: [PATCH] Suggestion: new module link

2009-01-18 Thread Bruno Haible
Hello Martin, Can you please also provide a unit test for this module? The minimal test is probably to - create one file, - use link() to create a new name for it, - then verify that the contents is the same, - then modify the contents of the first one, - then verify the contents is agai

Re: [PATCH] Suggestion: new module link

2009-01-18 Thread Bruno Haible
Hello, Martin Lambers wrote: > I'd like to suggest a new module 'link' that provides the link(2) > function for MinGW. Your patch looks quite fine. I have applied it with this ChangeLog entry 2009-01-18 Martin Lambers New module 'link'. * lib/unistd.in.h (link): New declarati

Re: filenamecat-tests & fstrcmp-tests: needs program_name symbol

2009-01-18 Thread Jim Meyering
Simon Josefsson wrote: > The self-test for filenamecat fails to build on darwin: > > http://autobuild.josefsson.org/gnulib/log-200901180512377089000.txt > > Which also breaks the canonicalize module: > > http://autobuild.josefsson.org/gnulib/log-200901180511842725000.txt > > The fstrcmp-tests has

Re: filenamecat-tests & fstrcmp-tests: needs program_name symbol

2009-01-18 Thread Bruno Haible
Simon Josefsson wrote: > How about the patch below? Tested on debian lenny x86 and mac os x > 10.4. Looks perfect. Additionally, a few tests are using module 'progname' but are not initializing it upon program startup. This fixes it. 2009-01-18 Bruno Haible * tests/test-avltree_lis

[PATCH] Suggestion: new module link

2009-01-18 Thread Martin Lambers
I'd like to suggest a new module 'link' that provides the link(2) function for MinGW. The module is modelled after the existing fsync module. Martin --- lib/link.c | 83 +++ lib/unistd.in.h | 17 +++ m4/link.m4 | 19

filenamecat-tests & fstrcmp-tests: needs program_name symbol

2009-01-18 Thread Simon Josefsson
The self-test for filenamecat fails to build on darwin: http://autobuild.josefsson.org/gnulib/log-200901180512377089000.txt Which also breaks the canonicalize module: http://autobuild.josefsson.org/gnulib/log-200901180511842725000.txt The fstrcmp-tests has the same problem: http://autobuild.jo

Re: gnulib update broke printf-args.c on IRIX 6.5

2009-01-18 Thread Thomas Guyot-Sionnest
On 16/01/09 09:36 AM, Albert Chin wrote: > On Fri, Jan 16, 2009 at 05:03:00AM -0500, Thomas Guyot-Sionnest wrote: >> I recently updated gnulib in the nagios-plugins source tree to fix >> issues with regex on HP-UX; unfortunately the update broke our IRIX >> 6.5 build. > > See this thread: > http

Re: working with "good enough" functions

2009-01-18 Thread Simon Josefsson
Bruno Haible writes: > Mike Frysinger and Simon Josefsson wrote: >> >> If this happens often enough, perhaps gnulib should have a >> >> printf-posix-no-fp module that does what you want? >> > >> > i would certainly use it, but if i'm the only one expressing interest thus >> > far, then maybe it

Re: LIBEXT

2009-01-18 Thread Bruno Haible
Werner LEMBERG replied to Ralf Wildenhues: > > > What about adding a test to find out the extension of (static) > > > libraries? Having a LIBEXT variable would be quite helpful. > > > > [...] you can alternatively use the gnulib module havelib (which > > will use the logic in the config.rpath file

new module alphasort

2009-01-18 Thread Bruno Haible
A companion function of scandir, also added in POSIX:2008, is alphasort. This adds the replacement, from glibc. 2009-01-18 Bruno Haible New module 'alphasort'. * lib/dirent.in.h (alphasort): New declaration. * lib/alphasort.c: New file, from glibc with modifications.

new module scandir

2009-01-18 Thread Bruno Haible
Another new function in POSIX:2008 is scandir. I cannot judge how useful it is, but it's easy to port the implementation from glibc anyway. 2009-01-18 Bruno Haible New module 'scandir'. * lib/dirent.in.h (scandir): New declaration. * lib/scandir.c: New file, from glibc