How good it's if we can have Bash internal variable as default for loop counter,
f(){
unset i
for a;{
let ++i
# ...
}
#...
}
so have that instead of $i for sake of efficieny or optimization,
could be named any, $/, $! etc
On 11/24/20 8:30 AM, Léa Gris wrote:
> Should variables automatically created within arithmetic constructs have
> the integer flag implied?
No. There's no reason to do this. If you want an integer variable, declare
it as such beforehand.
--
``The lyf so short, the craft so long to lerne.'' - Cha