RE: How to modify default tomcat http header property "Server: Apache-Coyote/1.1" ?

2008-02-22 Thread Hanks Wang (hanwan)
Get the answer, write it here in case someone meets same problem in
future:
 
add server attribute in Connector element of the conf/server.xml,
something like this:
 

 
Thanks
Han



From: Hanks Wang (hanwan) 
Sent: Friday, February 22, 2008 2:23 PM
To: 'dev@tomcat.apache.org'
Subject: How to modify default tomcat http header property "Server:
Apache-Coyote/1.1" ?


Hi all,
 
I deployed a servlet in Tomcat which response to all http post requests,
and I composed the response data by HttpServletResponse object.
 
But I found Tomcat will generate a default http header property in the
response: "Server: Apache-Coyote/1.1"
 
So my question is : Is there a way to change the http header value? eg:
change it to "Server: For-Test"
 
I try to use below method: 
response.setHeader("Server", "For-Test");
 
Then the http header becomes to:
Server: Apache-Coyote/1.1
Server: For-test
 
But the "Apache-Coyote/1.1" still there.  So how can I delete it or
modify it? Thanks!
 
B.R
Han
 


svn commit: r630119 - /tomcat/current/tc5.5.x/STATUS.txt

2008-02-22 Thread rjung
Author: rjung
Date: Fri Feb 22 00:48:18 2008
New Revision: 630119

URL: http://svn.apache.org/viewvc?rev=630119&view=rev
Log:
Propose Fix for BZ 44463 (applies only to TC 5.5).

Modified:
tomcat/current/tc5.5.x/STATUS.txt

Modified: tomcat/current/tc5.5.x/STATUS.txt
URL: 
http://svn.apache.org/viewvc/tomcat/current/tc5.5.x/STATUS.txt?rev=630119&r1=630118&r2=630119&view=diff
==
--- tomcat/current/tc5.5.x/STATUS.txt (original)
+++ tomcat/current/tc5.5.x/STATUS.txt Fri Feb 22 00:48:18 2008
@@ -40,3 +40,10 @@
   http://svn.apache.org/viewvc?rev=627883&view=rev
   +1: markt
   -1:
+
+* Fix http://issues.apache.org/bugzilla/show_bug.cgi?id=44463
+  war file upload during manager webapp deploy is broken
+  http://people.apache.org/~rjung/patches/add_commons-io.patch
+  NOTE: there are also references to commons-fileupload in the
+  container build.xml, but I think we don't need to add commons-io there.
+  +1: rjung



-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



Re: [ANN] Apache Tomcat 4.1.37 stable is released

2008-02-22 Thread Rainer Jung

Hello Mark,

I noticed today, that the names of the binary LE downloads have changed 
slightly and didn't fit what was in the download page.


I renamed all

apache-tomcat-4.1.37-LE-jdk1.4.*

to

apache-tomcat-4.1.37-LE-jdk14.*

(no dot between "jdk1" and "4".

I did it on www/dist and archives/dist. It's the notation used in 4.1.36 
and to which the download links refer. If you don't like it this way, 
and want to change everything to the dotted notation, then sorry.


Regards,

Rainer

Mark Thomas wrote:

The Apache Tomcat team is proud to announce the immediate availability
of Tomcat 4.1.37 stable. This build contains numerous library updates,
a small number of bug fixes and two important, one moderate and six low
severity security fixes.

Apache Tomcat is an implementation of the Java Server Pages 1.2 and
Java Servlet 2.3 specifications.

Please refer to the release notes for a complete list of changes.

Downloads:
http://tomcat.apache.org/download-41.cgi
Security information:
http://tomcat.apache.org/security-4.html

The Apache Tomcat Team


-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



DO NOT REPLY [Bug 44021] - Deployer cannot deploy wars with #s

2008-02-22 Thread bugzilla
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=44021





--- Additional Comments From [EMAIL PROTECTED]  2008-02-22 01:54 ---
I observed some unexpected behaviour when deploying a webapp using the Tomcat
Client Deployer (TCD) package and hashes ("#") in the deployed context path of
the webapp (I observed this using 6.0.16). In my humble opinion, using hashes in
the path is not very usual, but this may be somewhat related to this topic and
easy to fix if somebody works on the original issue.

It is possible to deploy a webapp to a context path "/foo#bar" using TCD.
Undeploying using TCD of this webapp fails, because the path is truncated at the
hash (resulting in "/foo") which results in an error. Undeploying using the
manager webapp results in the same error. An additional problem is, that in case
a webapp ist deployed at the context path "/foo", it will be undeployed when
trying to undeploy the webapp deployed at "/foo#bar".

A possible workaround is to undeploy the webapp using both TCD and manager
webapp when the hash ist replaced by "%23".

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
--- You are receiving this mail because: ---
You are the assignee for the bug, or are watching the assignee.

-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



DO NOT REPLY [Bug 28727] - CLOSE_WAIT connections draw 100 % cpu

2008-02-22 Thread bugzilla
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=28727


[EMAIL PROTECTED] changed:

   What|Removed |Added

 Status|RESOLVED|REOPENED
 OS/Version|Windows XP  |Solaris
 Resolution|INVALID |




--- Additional Comments From [EMAIL PROTECTED]  2008-02-22 04:20 ---
Same Problem faced on solaries10 related to CLOSE_WAIT.Even I reduced 
tcp_time_wait_interval kernel parameter 1(ms).

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
--- You are receiving this mail because: ---
You are the assignee for the bug, or are watching the assignee.

-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



Re: svn commit: r630043 - /tomcat/tc6.0.x/trunk/STATUS.txt

2008-02-22 Thread Filip Hanik - Dev Lists

[EMAIL PROTECTED] wrote:

Author: remm
@@ -80,6 +82,7 @@
   +1: fhanik, markt
   +0: remm (the property name is inconsistent with what has been used 
recently, but that
   convention was never really discussed either) fhanik: the propperty name 
is the same as everywhere else
+  I posted about that: could have its own property in addition to the strict thing, and the field should be uppercase 
   -1: 
  
you're writing "property" but if I'm finally interpreting correct what 
you actually mean is the static variable named switchToV1Cookies.
I have no problem changing the name of this, I could care less. When you 
said property I assumed you were talking about the system property 
org.apache.catalina.STRICT_SERVLET_COMPLIANCE.


I have no problem renaming the static variable, to be the same name as 
the other one used. that's a semantic I could really care less about


Filip
   
 * Fix ArrayIndexOutOfBoundsException when empty URL is requested




-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



  



-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



svn commit: r630231 - /tomcat/trunk/.project

2008-02-22 Thread fhanik
Author: fhanik
Date: Fri Feb 22 07:55:32 2008
New Revision: 630231

URL: http://svn.apache.org/viewvc?rev=630231&view=rev
Log:
correct project name

Modified:
tomcat/trunk/.project

Modified: tomcat/trunk/.project
URL: 
http://svn.apache.org/viewvc/tomcat/trunk/.project?rev=630231&r1=630230&r2=630231&view=diff
==
--- tomcat/trunk/.project (original)
+++ tomcat/trunk/.project Fri Feb 22 07:55:32 2008
@@ -16,7 +16,7 @@
   limitations under the License.
 -->
 
-   tomcat6
+   tomcat-trunk






-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



svn commit: r630234 - /tomcat/trunk/java/org/apache/catalina/tribes/transport/nio/NioReceiver.java

2008-02-22 Thread fhanik
Author: fhanik
Date: Fri Feb 22 08:01:41 2008
New Revision: 630234

URL: http://svn.apache.org/viewvc?rev=630234&view=rev
Log:
add in some more checks

Modified:
tomcat/trunk/java/org/apache/catalina/tribes/transport/nio/NioReceiver.java

Modified: 
tomcat/trunk/java/org/apache/catalina/tribes/transport/nio/NioReceiver.java
URL: 
http://svn.apache.org/viewvc/tomcat/trunk/java/org/apache/catalina/tribes/transport/nio/NioReceiver.java?rev=630234&r1=630233&r2=630234&view=diff
==
--- tomcat/trunk/java/org/apache/catalina/tribes/transport/nio/NioReceiver.java 
(original)
+++ tomcat/trunk/java/org/apache/catalina/tribes/transport/nio/NioReceiver.java 
Fri Feb 22 08:01:41 2008
@@ -279,9 +279,9 @@
 continue; // nothing to do
 }
 // get an iterator over the set of selected keys
-Iterator it = selector.selectedKeys().iterator();
+Iterator it = 
(selector!=null)?selector.selectedKeys().iterator():null;
 // look at each key in the selected set
-while (it.hasNext() && selector!=null) {
+while (selector!=null && it.hasNext()) {
 SelectionKey key = (SelectionKey) it.next();
 // Is a new connection coming in?
 if (key.isAcceptable()) {



-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



svn commit: r630235 - /tomcat/trunk/test/org/apache/catalina/tribes/test/channel/TestUdpPackages.java

2008-02-22 Thread fhanik
Author: fhanik
Date: Fri Feb 22 08:01:51 2008
New Revision: 630235

URL: http://svn.apache.org/viewvc?rev=630235&view=rev
Log:
more test changes

Modified:

tomcat/trunk/test/org/apache/catalina/tribes/test/channel/TestUdpPackages.java

Modified: 
tomcat/trunk/test/org/apache/catalina/tribes/test/channel/TestUdpPackages.java
URL: 
http://svn.apache.org/viewvc/tomcat/trunk/test/org/apache/catalina/tribes/test/channel/TestUdpPackages.java?rev=630235&r1=630234&r2=630235&view=diff
==
--- 
tomcat/trunk/test/org/apache/catalina/tribes/test/channel/TestUdpPackages.java 
(original)
+++ 
tomcat/trunk/test/org/apache/catalina/tribes/test/channel/TestUdpPackages.java 
Fri Feb 22 08:01:51 2008
@@ -56,7 +56,7 @@
 tint.setInterval(500);
 ThroughputInterceptor tint2 = new ThroughputInterceptor();
 tint2.setInterval(500);
-channel1.addInterceptor(tint);
+//channel1.addInterceptor(tint);
 channel2.addInterceptor(tint2);
 listener1 = new Listener();
 ReceiverBase rb1 = (ReceiverBase)channel1.getChannelReceiver();
@@ -138,31 +138,45 @@
 }
 
 public void testDataSendASYNCM() throws Exception {
-System.err.println("Starting ASYNC MULTI THREAD");
-Thread[] threads = new Thread[threadCount];
-for (int x=0; x

svn commit: r630314 - /tomcat/trunk/webapps/examples/WEB-INF/web.xml

2008-02-22 Thread fhanik
Author: fhanik
Date: Fri Feb 22 12:41:06 2008
New Revision: 630314

URL: http://svn.apache.org/viewvc?rev=630314&view=rev
Log:
correct the example URLs since the example webapp has been modified

Modified:
tomcat/trunk/webapps/examples/WEB-INF/web.xml

Modified: tomcat/trunk/webapps/examples/WEB-INF/web.xml
URL: 
http://svn.apache.org/viewvc/tomcat/trunk/webapps/examples/WEB-INF/web.xml?rev=630314&r1=630313&r2=630314&view=diff
==
--- tomcat/trunk/webapps/examples/WEB-INF/web.xml (original)
+++ tomcat/trunk/webapps/examples/WEB-INF/web.xml Fri Feb 22 12:41:06 2008
@@ -223,12 +223,12 @@
Special property group for JSP Configuration JSP example.

JSPConfiguration
-   /jsp2/misc/config.jsp
+   /jsp/jsp2/misc/config.jsp
true
ISO-8859-1
true
-   /jsp2/misc/prelude.jspf
-   /jsp2/misc/coda.jspf
+   /jsp/jsp2/misc/prelude.jspf
+   /jsp/jsp2/misc/coda.jspf

 
 



-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]



Re: [ANN] Apache Tomcat 4.1.37 stable is released

2008-02-22 Thread Mark Thomas

Rainer Jung wrote:
I did it on www/dist and archives/dist. It's the notation used in 4.1.36 
and to which the download links refer. If you don't like it this way, 
and want to change everything to the dotted notation, then sorry.


Thanks. Good catch.

Mark


-
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]