Patch: Remove some deprecated functions

2011-11-05 Thread Mauro
  Hi everyone,

while building calligra I have noticed many compiler warning related to
the use of deprecated functions. I have tried to remove as many as
possible among the most trivial (dates/locale functions).

While browsing the code I also came upon this strange if construct:

[filters/words/rtf/import/rtf-qt/src/UserPropsDestination.cpp]
38  if ( value == 30 ) {
39m_propertyType = QVariant::String;
40  } else if ( value == 3 ) {
41m_propertyType == QVariant::Int; // <-- statement with no effect
42  } else if ( value == 5 ) {
43m_propertyType == QVariant::Double; // again, no effect
} ... {
49qDebug() << "unhandled value type in UserPropsDestination:" << value;
50  }

I assumed that the idea was to *set* the m_propertyType field (as in row
39), so I have also fixed that in my patch.

On IRC boemann told me to post the patch here and to take this
opportunity to introduce briefly myself to the community. So... My name
is Mauro and I am a MSc student of Computer Engineering at PoliTO.

I know this is a patch of little value, but I hope to be able to do more
in the future.
Maybe some Junior Jobs...

Best,

-- 
Mauro Levra
nazardo :)
  "If you want to make an apple pie from scratch,
   you must first create the universe" -Carl Sagan 



patchDeprecated.diff.gz
Description: GNU Zip compressed data
___
calligra-devel mailing list
calligra-devel@kde.org
https://mail.kde.org/mailman/listinfo/calligra-devel


Re: Patch: Remove some deprecated functions

2011-11-06 Thread Mauro
Hello Thorsten,

On Sunday, November 06, 2011 05:13 Thorsten Zachmann wrote:
> What part of Calligra does interest you the most?

As a developer I have no preferences, since I know near nothing of
Calligra code; so if there is one part that is in more need, or that is
easier to start with, I will become interested in that.
As a user I like what Krita has become, a rich and powerful alternative
to well-known commercial softwares.

> The function 
> 
> formatDate(date, KLocale::MonthName, KLocale::ShortName) 
> 
> was introduced in 4.6 so you need to ifdef that as we still support compiling 
> against kde 4.4.

I apologize, I didn't know you still need to support KDE 4.4
I have removed the formatDate() stuff, since the deprecated methods it
substitutes will not be removed by KDE 5 and the introduction of dozens
of compilation switches would have compromised readability.

> It would be good if Marjin and Dan the maintainers of tables/plan would have 
> a 
> look too just to make sure all is still fine.
> 
> It would be very appreciated if you can post your next patch to reviewboard 
> as 
> it makes reviewing much simpler.

I will post there my updated patch.

Thanks,

-- 
Mauro Levra
nazardo :)
  "You've got questions. We've got dancing paperclips" -Microsoft
___
calligra-devel mailing list
calligra-devel@kde.org
https://mail.kde.org/mailman/listinfo/calligra-devel


Re: Calligra Branding Presentation & Draft of Guidelines

2011-11-12 Thread Mauro
  Hello,

Jaroslaw Staniek wrote:
> Please discuss here about important things like terms of use of the
> logo in the context of the Calligra Project

I am not an expert in digital rights and logo licensing, but I can't see
why the "Avoid mistakes" section is so restrictive.
> Do not incorporate the Calligra Suite logo
> into any other design, and never add new elements to the logo.
Doesn't that prevent most of the usages a logo can have (icons, banners
etc.)?

-- 
Mauro Levra
nazardo :)
  "The day Microsoft makes a product that doesn't suck,
   is the day they make a vacuum cleaner." -Anonymous
___
calligra-devel mailing list
calligra-devel@kde.org
https://mail.kde.org/mailman/listinfo/calligra-devel


Re: Voting for the best name for the Caligra Spreadsheet Application

2011-11-14 Thread Mauro
I'd like to share with you two names that just came to my mind:

* tabella/tabellae/tabulae [1]
  Latin for table(s)
* abacus
  well known simple calculating tool

What's your opinion?

I'm not a contributor, so maybe I don't qualify, but I would like to be
able to vote.

[1] I can't give you the exact version to use as a "name", but if you
are interested I can ask a person who has studied Latin.

-- 
Mauro Levra
___
calligra-devel mailing list
calligra-devel@kde.org
https://mail.kde.org/mailman/listinfo/calligra-devel


Review Request: Remove some deprecated calls and fix a typing error

2011-11-06 Thread Mauro Levra

---
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/103057/
---

Review request for Calligra.


Description
---

Remove some deprecated calls (dates/locale) and fix a typing error (== instead 
of =).


Diffs
-

  filters/tables/opencalc/opencalcexport.cc ab32787 
  filters/words/rtf/import/rtf-qt/src/UserPropsDestination.cpp 4e6d185 
  plan/libs/kernel/kptcommand.cpp 74c4979 
  plan/libs/models/kcalendar/kdatepicker.cpp 94e7da38 
  plan/libs/models/kcalendar/kdatetable.cpp 57ed05d 
  plan/plugins/schedulers/tj/taskjuggler/TjMessageHandler.cpp 066036f 
  plan/plugins/schedulers/tj/taskjuggler/Utility.cpp 113a442 
  tables/plugins/calendar/CalendarTool.cpp 44e4cf4 
  tables/ui/CellToolBase.cpp 8c0d66a 
  tables/ui/CellToolBase_p.cpp 5d3cf73 

Diff: http://git.reviewboard.kde.org/r/103057/diff/diff


Testing
---

Only built it and related warnings were gone.


Thanks,

Mauro Levra

___
calligra-devel mailing list
calligra-devel@kde.org
https://mail.kde.org/mailman/listinfo/calligra-devel