[Lldb-commits] [PATCH] D89812: [lldb][PDB] Add ObjectFile PDB plugin

2020-10-22 Thread Pavel Labath via Phabricator via lldb-commits
labath added inline comments. Comment at: lldb/source/Plugins/ObjectFile/PDB/ObjectFilePDB.cpp:176-197 + switch (dbi_stream->getMachineType()) { + case PDB_Machine::Amd64: +spec.SetTriple("x86_64-pc-windows"); +specs.Append(module_spec); +break; + case PDB_Machine:

[Lldb-commits] [PATCH] D89925: [lldb] Fix a regression introduced by D75730

2020-10-22 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. If needed, we can add some `#ifdef`s to produce suitable instructions on other architectures too. Comment at: lldb/source/Core/Disassembler.cpp:544

[Lldb-commits] [PATCH] D89874: [lldb] Unify x86 watchpoint implementation on Linux and NetBSD (and future FreeBSD plugin) [WIP]

2020-10-22 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. This looks very nice. In D89874#2344759 , @mgorny wrote: > In D89874#2344561 , @labath wrote: > >> I like this, and I think this is in a pretty good shape as it stands. The >> thing I'm not

[Lldb-commits] [PATCH] D89600: [lldb] Move copying of reproducer out of process

2020-10-22 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. In D89600#2338996 , @JDevlieghere wrote: > In D89600#2337868 , @labath wrote: > >> Hm... Are you sure that this will help with anything? IIUC, the >> serialization of the VFS file map still

[Lldb-commits] [lldb] bb1d702 - [lldb][NFC] Make GetShellSafeArgument return std::string and unittest it.

2020-10-22 Thread Raphael Isemann via lldb-commits
Author: Raphael Isemann Date: 2020-10-22T14:47:10+02:00 New Revision: bb1d702e25f5f23e8d5a755295f2921caaea2abb URL: https://github.com/llvm/llvm-project/commit/bb1d702e25f5f23e8d5a755295f2921caaea2abb DIFF: https://github.com/llvm/llvm-project/commit/bb1d702e25f5f23e8d5a755295f2921caaea2abb.dif

[Lldb-commits] [PATCH] D89813: [CMake][NFC] Limit the use of uppercase_CMAKE_BUILD_TYPE

2020-10-22 Thread Christopher Tetreault via Phabricator via lldb-commits
ctetreau added a comment. I would assume so. I'll take a look. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D89813/new/ https://reviews.llvm.org/D89813 ___ lldb-commits mailing list lldb-commits@lists.ll

[Lldb-commits] [PATCH] D89813: [CMake][NFC] Limit the use of uppercase_CMAKE_BUILD_TYPE

2020-10-22 Thread Louis Dionne via Phabricator via lldb-commits
ldionne added a comment. I quite like this. We should strive to use the same name as CMake uses for its build types, i.e. `Debug`, `Release`, etc. If I configure CMake with `-DCMAKE_BUILD_TYPE=DEBUG`, is `CMAKE_BUILD_TYPE` normalized back to `Debug` by CMake, or is it defined to `DEBUG`? If the

[Lldb-commits] [PATCH] D89813: [CMake][NFC] Limit the use of uppercase_CMAKE_BUILD_TYPE

2020-10-22 Thread Christopher Tetreault via Phabricator via lldb-commits
ctetreau marked an inline comment as done. ctetreau added a comment. In D89813#2342463 , @ldionne wrote: > I quite like this. We should strive to use the same name as CMake uses for > its build types, i.e. `Debug`, `Release`, etc. > > If I configure CMake

[Lldb-commits] [PATCH] D89813: [CMake][NFC] Limit the use of uppercase_CMAKE_BUILD_TYPE

2020-10-22 Thread Christopher Tetreault via Phabricator via lldb-commits
ctetreau created this revision. Herald added subscribers: llvm-commits, libcxx-commits, lldb-commits, Sanitizers, lebedev.ri, hiraditya, arichardson, mgorny. Herald added a reviewer: lebedev.ri. Herald added projects: Sanitizers, LLDB, libc++, libc++abi, libunwind, LLVM. Herald added a reviewer: l

[Lldb-commits] [PATCH] D89813: [CMake][NFC] Limit the use of uppercase_CMAKE_BUILD_TYPE

2020-10-22 Thread Christopher Tetreault via Phabricator via lldb-commits
ctetreau added a comment. In D89813#2342552 , @ctetreau wrote: > I would assume so. I'll take a look. It doesn't seem to work. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D89813/new/ https://reviews.llvm.

[Lldb-commits] [PATCH] D89813: [CMake][NFC] Limit the use of uppercase_CMAKE_BUILD_TYPE

2020-10-22 Thread Louis Dionne via Phabricator via lldb-commits
ldionne added a comment. Are generator expressions expanded in `if()`? If so, we could at least change those to `if ("$" STREQUAL "DEBUG")`. This would preserve the case-insensitivity while solving the problem you were concerned about, and make the code easier to read. Repository: rG LLVM G

[Lldb-commits] [PATCH] D89842: [lldb/DWARF] Add support for DW_OP_implicit_value

2020-10-22 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib updated this revision to Diff 299540. mib added a comment. Add test. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D89842/new/ https://reviews.llvm.org/D89842 Files: lldb/source/Expression/DWARFExpression.cpp lldb/test/Shell/SymbolFile/DWAR

[Lldb-commits] [PATCH] D89842: [lldb/DWARF] Add support DW_OP_implicit_value

2020-10-22 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib created this revision. mib added reviewers: labath, JDevlieghere, aprantl. mib added projects: LLDB, debug-info. Herald added a subscriber: lldb-commits. mib requested review of this revision. This patch completes https://reviews.llvm.org/D83560. Now that the compiler can emit `DW_OP_implicit_

[Lldb-commits] [PATCH] D89813: [CMake][NFC] Limit the use of uppercase_CMAKE_BUILD_TYPE

2020-10-22 Thread Roman Lebedev via Phabricator via lldb-commits
lebedev.ri requested changes to this revision. lebedev.ri added inline comments. This revision now requires changes to proceed. Comment at: libcxx/utils/google-benchmark/test/CMakeLists.txt:8-9 # strip -DNDEBUG from the default CMake flags in DEBUG mode. -string(TOUPPER "${CMAKE

[Lldb-commits] [PATCH] D89842: [lldb/DWARF] Add support for DW_OP_implicit_value

2020-10-22 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib updated this revision to Diff 299539. mib retitled this revision from "[lldb/DWARF] Add support DW_OP_implicit_value" to "[lldb/DWARF] Add support for DW_OP_implicit_value". mib edited the summary of this revision. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://rev

[Lldb-commits] [PATCH] D89842: [lldb/DWARF] Add support for DW_OP_implicit_value

2020-10-22 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. The code looks pretty straight-forward, but I believe the test should be asm-based with hardcoded dwarf (if you're feeling adventurous, you can also try yaml). My reasons for that are: - it makes it guarantees (and makes it explicit) the input that is being tested - the

[Lldb-commits] [PATCH] D89842: [lldb/DWARF] Add support for DW_OP_implicit_value

2020-10-22 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib updated this revision to Diff 299941. mib edited the summary of this revision. mib added a comment. Change shell test for unit test. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D89842/new/ https://reviews.llvm.org/D89842 Files: lldb/source/

[Lldb-commits] [PATCH] D89842: [lldb/DWARF] Add support for DW_OP_implicit_value

2020-10-22 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. In D89842#2345947 , @aprantl wrote: > Perhaps the test fits in here > https://github.com/llvm/llvm-project/blob/master/lldb/unittests/Expression/DWARFExpressionTest.cpp > ? Yes, that's even better. :) Repository: rG LLVM Gith

[Lldb-commits] [PATCH] D89842: [lldb/DWARF] Add support for DW_OP_implicit_value

2020-10-22 Thread Adrian Prantl via Phabricator via lldb-commits
aprantl added a comment. Perhaps the test fits in here https://github.com/llvm/llvm-project/blob/master/lldb/unittests/Expression/DWARFExpressionTest.cpp ? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D89842/new/ https://reviews.llvm.org/D89842

[Lldb-commits] [PATCH] D89842: [lldb/DWARF] Add support for DW_OP_implicit_value

2020-10-22 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added a comment. +1 on everything Pavel said. Comment at: lldb/source/Expression/DWARFExpression.cpp:856-867 + const uint32_t len = opcodes.GetULEB128(&opcode_offset); + const void *data = opcodes.GetData(&opcode_offset, len); + + if (!data) { +LLDB_LOG(log,

[Lldb-commits] [lldb] 4118522 - [lldb] Explicitly use the configuration architecture when building test executables

2020-10-22 Thread Raphael Isemann via lldb-commits
Author: Raphael Isemann Date: 2020-10-22T15:30:25+02:00 New Revision: 41185226f6d80663b4a1064c6f47581ee567d78d URL: https://github.com/llvm/llvm-project/commit/41185226f6d80663b4a1064c6f47581ee567d78d DIFF: https://github.com/llvm/llvm-project/commit/41185226f6d80663b4a1064c6f47581ee567d78d.dif

[Lldb-commits] [PATCH] D89056: [lldb] Explicitly use the configuration architecture when building test executables

2020-10-22 Thread Raphael Isemann via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG41185226f6d8: [lldb] Explicitly use the configuration architecture when building test… (authored by teemperor). Herald added a project: LLDB. Herald added a subscriber: lldb-commits. Repository: rG LLVM

[Lldb-commits] [PATCH] D89874: [lldb] Split out NetBSD/x86 watchpoint impl for unification

2020-10-22 Thread Michał Górny via Phabricator via lldb-commits
mgorny updated this revision to Diff 299950. mgorny retitled this revision from "[lldb] Unify x86 watchpoint implementation on Linux and NetBSD (and future FreeBSD plugin) [WIP]" to "[lldb] Split out NetBSD/x86 watchpoint impl for unification". mgorny edited the summary of this revision. mgorny a

[Lldb-commits] [PATCH] D89698: [lldb] Fix TestTargetAPI.py on Apple simulators

2020-10-22 Thread Raphael Isemann via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG30d5590d171c: [lldb] Fix TestTargetAPI.py on Apple simulators (authored by teemperor). Herald added a project: LLDB. Herald added a subscriber: lldb-commits. Repository: rG LLVM Github Monorepo CHANGES

[Lldb-commits] [lldb] 30d5590 - [lldb] Fix TestTargetAPI.py on Apple simulators

2020-10-22 Thread Raphael Isemann via lldb-commits
Author: Raphael Isemann Date: 2020-10-22T16:41:54+02:00 New Revision: 30d5590d171c40e05b65585d1b531d8489e783e2 URL: https://github.com/llvm/llvm-project/commit/30d5590d171c40e05b65585d1b531d8489e783e2 DIFF: https://github.com/llvm/llvm-project/commit/30d5590d171c40e05b65585d1b531d8489e783e2.dif

[Lldb-commits] [PATCH] D89925: [lldb] Fix a regression introduced by D75730

2020-10-22 Thread Jonas Devlieghere via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rG826997c46280: [lldb] Fix a regression introduced by D75730 (authored by JDevlieghere). Changed prior to commit: https://reviews.llvm.org/D89925?vs

[Lldb-commits] [lldb] 826997c - [lldb] Fix a regression introduced by D75730

2020-10-22 Thread Jonas Devlieghere via lldb-commits
Author: Jonas Devlieghere Date: 2020-10-22T08:38:03-07:00 New Revision: 826997c46280351861be43522d4a022d8fdbc466 URL: https://github.com/llvm/llvm-project/commit/826997c46280351861be43522d4a022d8fdbc466 DIFF: https://github.com/llvm/llvm-project/commit/826997c46280351861be43522d4a022d8fdbc466.d

[Lldb-commits] [lldb] efe62b6 - [lldb/DWARF] Add support for DW_OP_implicit_value

2020-10-22 Thread Med Ismail Bennani via lldb-commits
Author: Med Ismail Bennani Date: 2020-10-22T18:02:44+02:00 New Revision: efe62b637d51f6d622589132075320dd4f687478 URL: https://github.com/llvm/llvm-project/commit/efe62b637d51f6d622589132075320dd4f687478 DIFF: https://github.com/llvm/llvm-project/commit/efe62b637d51f6d622589132075320dd4f687478.

[Lldb-commits] [lldb] 5dc7033 - Revert "[lldb] Explicitly use the configuration architecture when building test executables"

2020-10-22 Thread Raphael Isemann via lldb-commits
Author: Raphael Isemann Date: 2020-10-22T18:42:19+02:00 New Revision: 5dc70332d53cc5744aedf72a12d0367988559776 URL: https://github.com/llvm/llvm-project/commit/5dc70332d53cc5744aedf72a12d0367988559776 DIFF: https://github.com/llvm/llvm-project/commit/5dc70332d53cc5744aedf72a12d0367988559776.dif

[Lldb-commits] [PATCH] D89600: [lldb] Move copying of reproducer out of process

2020-10-22 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere updated this revision to Diff 300051. JDevlieghere marked 6 inline comments as done. JDevlieghere added a comment. Address Pavel's code review feedback CHANGES SINCE LAST ACTION https://reviews.llvm.org/D89600/new/ https://reviews.llvm.org/D89600 Files: lldb/include/lldb/API/S

[Lldb-commits] [PATCH] D87172: Check if debug line sequences are starting after the first code segment

2020-10-22 Thread António Afonso via Phabricator via lldb-commits
aadsm added inline comments. Comment at: lldb/test/Shell/SymbolFile/DWARF/line-entries-invalid-addresses.yaml:3 +# RUN: %lldb %t -b -o "image lookup -f main.cpp -l 2 -v" | FileCheck %s +# CHECK: LineEntry: {{.*}}main.cpp:2:{{.*}} + labath wrote: > I think you al

[Lldb-commits] [PATCH] D87172: Check if debug line sequences are starting after the first code segment

2020-10-22 Thread António Afonso via Phabricator via lldb-commits
aadsm updated this revision to Diff 300131. aadsm added a comment. Check all child sections and makes sure the section is an actual code section. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D87172/new/ https://reviews.llvm.org/D87172 Files: lld

[Lldb-commits] [PATCH] D89812: [lldb][PDB] Add ObjectFile PDB plugin

2020-10-22 Thread Zequan Wu via Phabricator via lldb-commits
zequanwu added inline comments. Comment at: lldb/source/Plugins/ObjectFile/PDB/ObjectFilePDB.cpp:176-197 + switch (dbi_stream->getMachineType()) { + case PDB_Machine::Amd64: +spec.SetTriple("x86_64-pc-windows"); +specs.Append(module_spec); +break; + case PDB_Machin

[Lldb-commits] [PATCH] D89812: [lldb][PDB] Add ObjectFile PDB plugin

2020-10-22 Thread Zequan Wu via Phabricator via lldb-commits
zequanwu updated this revision to Diff 300133. zequanwu marked 4 inline comments as done. zequanwu added a comment. Herald added a subscriber: arphaman. Address some comments. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D89812/new/ https://reviews

[Lldb-commits] [PATCH] D89283: [trace][intel-pt] Implement the basic decoding functionality

2020-10-22 Thread walter erquinigo via Phabricator via lldb-commits
wallace updated this revision to Diff 300134. wallace added a comment. The diff is the now ready for review. There are a few updates, including some design decisions after some chats with Greg. - Now the dump command includes disassembly information and symbol context information whenever relev

[Lldb-commits] [PATCH] D89999: [lldb] Implement ObjCGetClassNameRaw using a UtilityFunction

2020-10-22 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere created this revision. JDevlieghere added a reviewer: jingham. JDevlieghere requested review of this revision. The static function ObjCGetClassNameRaw in AppleObjCRuntimeV2.cpp gets called fairly frequently to resolve the names of classes. It runs a UserExpression, rather than maki

[Lldb-commits] [PATCH] D89999: [lldb] Implement ObjCGetClassNameRaw using a UtilityFunction

2020-10-22 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere updated this revision to Diff 300140. JDevlieghere added a comment. - Remove accidentally staged changes CHANGES SINCE LAST ACTION https://reviews.llvm.org/D8/new/ https://reviews.llvm.org/D8 Files: lldb/source/Plugins/LanguageRuntime/ObjC/AppleObjCRuntime/AppleObjCRu

[Lldb-commits] [lldb] a00acba - [lldb] Fix missing initialization in UtilityFunction ctor (NFC)

2020-10-22 Thread Jonas Devlieghere via lldb-commits
Author: Jonas Devlieghere Date: 2020-10-22T21:12:27-07:00 New Revision: a00acbab45b0c407da05bf5c8152018e1857a1f0 URL: https://github.com/llvm/llvm-project/commit/a00acbab45b0c407da05bf5c8152018e1857a1f0 DIFF: https://github.com/llvm/llvm-project/commit/a00acbab45b0c407da05bf5c8152018e1857a1f0.d

[Lldb-commits] [lldb] 3590a83 - [lldb] Fix bug instroduced by a00acbab45b0

2020-10-22 Thread Jonas Devlieghere via lldb-commits
Author: Jonas Devlieghere Date: 2020-10-22T22:17:11-07:00 New Revision: 3590a8319a5fb491cba2349509910c2479f49a00 URL: https://github.com/llvm/llvm-project/commit/3590a8319a5fb491cba2349509910c2479f49a00 DIFF: https://github.com/llvm/llvm-project/commit/3590a8319a5fb491cba2349509910c2479f49a00.d

[Lldb-commits] [PATCH] D90011: [lldb] Redesign Target::GetUtilityFunctionForLanguage API

2020-10-22 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere created this revision. JDevlieghere added reviewers: jingham, labath, LLDB. Herald added a subscriber: emaste. JDevlieghere requested review of this revision. This patch redesigns the `Target::GetUtilityFunctionForLanguage` API: - Use a `unique_ptr` instead of a raw pointer for the r