[Lldb-commits] [lldb] r262920 - Use c_str() instead of GetCString() to fix build

2016-03-08 Thread Ewan Crawford via lldb-commits
Author: ewancrawford Date: Tue Mar 8 04:03:23 2016 New Revision: 262920 URL: http://llvm.org/viewvc/llvm-project?rev=262920&view=rev Log: Use c_str() instead of GetCString() to fix build Modified: lldb/trunk/source/Interpreter/CommandInterpreter.cpp Modified: lldb/trunk/source/Interpreter

[Lldb-commits] [lldb] r262923 - Try to fix windows build after rL262863

2016-03-08 Thread Tamas Berghammer via lldb-commits
Author: tberghammer Date: Tue Mar 8 05:43:56 2016 New Revision: 262923 URL: http://llvm.org/viewvc/llvm-project?rev=262923&view=rev Log: Try to fix windows build after rL262863 Modified: lldb/trunk/source/Plugins/Process/Windows/MiniDump/ProcessWinMiniDump.cpp Modified: lldb/trunk/source/P

[Lldb-commits] [PATCH] D17957: Expression evaluation for overloaded C functions

2016-03-08 Thread Ewan Crawford via lldb-commits
EwanCrawford created this revision. EwanCrawford added reviewers: spyffe, clayborg. EwanCrawford added a subscriber: lldb-commits. EwanCrawford set the repository for this revision to rL LLVM. Fixes bugzilla ticket https://llvm.org/bugs/show_bug.cgi?id=26694 Where we can currently pick the incorre

[Lldb-commits] [lldb] r262925 - Fix log in Broadcaster causing a crash

2016-03-08 Thread Tamas Berghammer via lldb-commits
Author: tberghammer Date: Tue Mar 8 07:33:14 2016 New Revision: 262925 URL: http://llvm.org/viewvc/llvm-project?rev=262925&view=rev Log: Fix log in Broadcaster causing a crash Modified: lldb/trunk/source/Core/Broadcaster.cpp Modified: lldb/trunk/source/Core/Broadcaster.cpp URL: http://llvm

Re: [Lldb-commits] [PATCH] D17897: Support floating point values in 128-bit SSE vector registers

2016-03-08 Thread Greg Clayton via lldb-commits
clayborg accepted this revision. clayborg added a comment. This revision is now accepted and ready to land. Looks good. Repository: rL LLVM http://reviews.llvm.org/D17897 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm

Re: [Lldb-commits] [PATCH] D17860: Fix "ninja check-lldb" crash in IRExecutionUnit.cpp

2016-03-08 Thread Adrian McCarthy via lldb-commits
amccarth accepted this revision. amccarth added a comment. This revision is now accepted and ready to land. Thanks for the fix. Right now I'm trying to figure out why the test framework didn't detect the crash and reported that all the tests passed. Comment at: source/Expressi

Re: [Lldb-commits] [PATCH] D17860: Fix "ninja check-lldb" crash in IRExecutionUnit.cpp

2016-03-08 Thread Sean Callanan via lldb-commits
spyffe accepted this revision. spyffe added a comment. Looks good to me. Thanks for the fix! Comment at: source/Expression/IRExecutionUnit.cpp:802 @@ -801,3 +801,3 @@ -load_address = candidate_sc.symbol->ResolveCallableAddress(*target); +l

[Lldb-commits] [lldb] r262947 - Support floating point values in 128-bit SSE vector registers

2016-03-08 Thread Adrian Prantl via lldb-commits
Author: adrian Date: Tue Mar 8 12:35:09 2016 New Revision: 262947 URL: http://llvm.org/viewvc/llvm-project?rev=262947&view=rev Log: Support floating point values in 128-bit SSE vector registers The System-V x86_64 ABI requires floating point values to be passed in 128-but SSE vector registers (x

Re: [Lldb-commits] [PATCH] D17897: Support floating point values in 128-bit SSE vector registers

2016-03-08 Thread Adrian Prantl via lldb-commits
aprantl closed this revision. aprantl added a comment. Thanks! Committed as r262947. Repository: rL LLVM http://reviews.llvm.org/D17897 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-

[Lldb-commits] [lldb] r262950 - Made self.expect() errors a little more readable in the testsuite.

2016-03-08 Thread Sean Callanan via lldb-commits
Author: spyffe Date: Tue Mar 8 12:58:48 2016 New Revision: 262950 URL: http://llvm.org/viewvc/llvm-project?rev=262950&view=rev Log: Made self.expect() errors a little more readable in the testsuite. self.expect() had two problems: - If there was a substrs argument, then it overwrote the variabl

Re: [Lldb-commits] [PATCH] D17860: Fix "ninja check-lldb" crash in IRExecutionUnit.cpp

2016-03-08 Thread Jim Ingham via lldb-commits
jingham added a subscriber: jingham. jingham added a comment. I don't think this is right. It is possible to have a sc.symbol be nullptr, but sc.function be valid. So the check for sc.symbol will reject the valid information in the function. Note, the code in the function is also wrong, sinc

Re: [Lldb-commits] [PATCH] D17860: Fix "ninja check-lldb" crash in IRExecutionUnit.cpp

2016-03-08 Thread Jim Ingham via lldb-commits
jingham added a comment. Greg suggests adding something to SymbolContext to get the start address of the function that handles this possibility. GetAddressRange sort of does this, but only if the SymbolContext doesn't have a block or line entry. http://reviews.llvm.org/D17860 _

Re: [Lldb-commits] [lldb] r262863 - Change over the broadcaster/listener process to hold shared or weak pointers

2016-03-08 Thread Jim Ingham via lldb-commits
Thanks, Tamas, sorry I missed that. Looks like everything is green again. Jim > On Mar 8, 2016, at 5:39 AM, Tamas Berghammer wrote: > > I committed in a fix as rL262925 (initialization order issue in a log line) > > On Tue, Mar 8, 2016 at 3:04 AM Jim Ingham via lldb-commits > wrote: > I

[Lldb-commits] [lldb] r262958 - Move CommandAlias to its own file; also

2016-03-08 Thread Enrico Granata via lldb-commits
Author: enrico Date: Tue Mar 8 15:23:30 2016 New Revision: 262958 URL: http://llvm.org/viewvc/llvm-project?rev=262958&view=rev Log: Move CommandAlias to its own file; also Store std::unique_ptr instead of instances Added: lldb/trunk/include/lldb/Interpreter/CommandAlias.h lldb/trunk/sou

[Lldb-commits] [lldb] r262959 - Add CommandAlias.cpp to CMakeLists

2016-03-08 Thread Enrico Granata via lldb-commits
Author: enrico Date: Tue Mar 8 15:29:49 2016 New Revision: 262959 URL: http://llvm.org/viewvc/llvm-project?rev=262959&view=rev Log: Add CommandAlias.cpp to CMakeLists Modified: lldb/trunk/source/Interpreter/CMakeLists.txt Modified: lldb/trunk/source/Interpreter/CMakeLists.txt URL: http://l

Re: [Lldb-commits] [PATCH] D17860: Fix "ninja check-lldb" crash in IRExecutionUnit.cpp

2016-03-08 Thread Ted Woodward via lldb-commits
ted added a comment. The change is to guard against the case where candidate_sc.symbol is nullptr. candidate_sc.function is only used when load_address != LLDB_INVALID_ADDRESS, but load_address is set on line 802: load_address = candidate_sc.symbol->ResolveCallableAddress(*target); so candid

Re: [Lldb-commits] [PATCH] D17860: Fix "ninja check-lldb" crash in IRExecutionUnit.cpp

2016-03-08 Thread Ted Woodward via lldb-commits
ted updated this revision to Diff 50074. ted added a comment. Updated to use early-out as requested http://reviews.llvm.org/D17860 Files: source/Expression/IRExecutionUnit.cpp Index: source/Expression/IRExecutionUnit.cpp === ---

[Lldb-commits] [PATCH] D17970: Implement ObjectFilePECOFF::GetEntryPointAddress.

2016-03-08 Thread Stephane Sezer via lldb-commits
sas created this revision. sas added reviewers: zturner, clayborg. sas added a subscriber: lldb-commits. http://reviews.llvm.org/D17970 Files: source/Plugins/ObjectFile/PECOFF/ObjectFilePECOFF.cpp source/Plugins/ObjectFile/PECOFF/ObjectFilePECOFF.h Index: source/Plugins/ObjectFile/PECOFF/Obj

Re: [Lldb-commits] [PATCH] D17970: Implement ObjectFilePECOFF::GetEntryPointAddress.

2016-03-08 Thread Zachary Turner via lldb-commits
zturner added a comment. Looks pretty non-controversial. Does this fix anything? Seems like there should be a test that breaks somehow if this doesn't work. I don't know off the top of my head what the debugger command is "get the address of the entry point", but presumably it was broken bef

Re: [Lldb-commits] [PATCH] D17970: Implement ObjectFilePECOFF::GetEntryPointAddress.

2016-03-08 Thread Greg Clayton via lldb-commits
clayborg requested changes to this revision. clayborg added a comment. This revision now requires changes to proceed. ObjectFilePECOFF::GetEntryPointAddress() is not implemented correctly. See inlined comments. Comment at: source/Plugins/ObjectFile/PECOFF/ObjectFilePECOFF.cpp:8

[Lldb-commits] [PATCH] D17972: [TestRegisterVariables] Adjust compiler range in expected failure decorator.

2016-03-08 Thread Siva Chandra via lldb-commits
sivachandra created this revision. sivachandra added a subscriber: lldb-commits. http://reviews.llvm.org/D17972 Files: packages/Python/lldbsuite/test/lang/c/register_variables/TestRegisterVariables.py Index: packages/Python/lldbsuite/test/lang/c/register_variables/TestRegisterVariables.py ==

Re: [Lldb-commits] [PATCH] D17860: Fix "ninja check-lldb" crash in IRExecutionUnit.cpp

2016-03-08 Thread Jim Ingham via lldb-commits
> On Mar 8, 2016, at 2:46 PM, Ted Woodward wrote: > > ted added a comment. > > The change is to guard against the case where candidate_sc.symbol is nullptr. > > candidate_sc.function is only used when load_address != LLDB_INVALID_ADDRESS, > but load_address is set on line 802: > > load_addr

Re: [Lldb-commits] [PATCH] D17970: Implement ObjectFilePECOFF::GetEntryPointAddress.

2016-03-08 Thread Greg Clayton via lldb-commits
clayborg added a comment. lldb_private::Address is a section offset address class. We use section offset addresses everywhere. We also have the notion of three types of addresses: file address, load address and host address. File addresses are virtual addresses as they are found in the object f

Re: [Lldb-commits] [PATCH] D17972: [TestRegisterVariables] Adjust compiler range in expected failure decorator.

2016-03-08 Thread Siva Chandra via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL262970: [TestRegisterVariables] Adjust compiler range in expected failure decorator. (authored by sivachandra). Changed prior to commit: http://reviews.llvm.org/D17972?vs=50079&id=50086#toc Repository:

[Lldb-commits] [lldb] r262970 - [TestRegisterVariables] Adjust compiler range in expected failure decorator.

2016-03-08 Thread Siva Chandra via lldb-commits
Author: sivachandra Date: Tue Mar 8 18:02:00 2016 New Revision: 262970 URL: http://llvm.org/viewvc/llvm-project?rev=262970&view=rev Log: [TestRegisterVariables] Adjust compiler range in expected failure decorator. Subscribers: lldb-commits Differential Revision: http://reviews.llvm.org/D17972

Re: [Lldb-commits] [PATCH] D17970: Implement ObjectFilePECOFF::GetEntryPointAddress.

2016-03-08 Thread Jim Ingham via lldb-commits
We use the entry point address as the place to stop when we call functions by hand in the target. That's one place which is legit TEXT, but we are pretty sure the code you are calling will never call. So if the entry point address isn't set correctly we probably won't be able to call any funct

Re: [Lldb-commits] [PATCH] D17970: Implement ObjectFilePECOFF::GetEntryPointAddress.

2016-03-08 Thread Jim Ingham via lldb-commits
jingham added a subscriber: jingham. jingham added a comment. We use the entry point address as the place to stop when we call functions by hand in the target. That's one place which is legit TEXT, but we are pretty sure the code you are calling will never call. So if the entry point address

Re: [Lldb-commits] [PATCH] D17970: Implement ObjectFilePECOFF::GetEntryPointAddress.

2016-03-08 Thread Zachary Turner via lldb-commits
zturner added a subscriber: zturner. zturner added a comment. I was hoping there would be something like `image headers` that would just display various information about the image, but it looks like we don't have such a command that I can find. Seems like being able to find out the entry point o

Re: [Lldb-commits] [PATCH] D17970: Implement ObjectFilePECOFF::GetEntryPointAddress.

2016-03-08 Thread Zachary Turner via lldb-commits
I was hoping there would be something like `image headers` that would just display various information about the image, but it looks like we don't have such a command that I can find. Seems like being able to find out the entry point of a certain module would be useful. On Tue, Mar 8, 2016 at 4:0

[Lldb-commits] [lldb] r262986 - Last round of preliminary cleanup in my refactoring of aliases.

2016-03-08 Thread Enrico Granata via lldb-commits
Author: enrico Date: Tue Mar 8 20:27:57 2016 New Revision: 262986 URL: http://llvm.org/viewvc/llvm-project?rev=262986&view=rev Log: Last round of preliminary cleanup in my refactoring of aliases. The next step is to actually turn CommandAlias into a full-blown CommandObject citizen. This is tr