Why not just send it in as is.  I use SQLite (via sqldf) and here is
the way I write my SQL statements:

    inRange <- sqldf('
        select t.*
                , r.start
                , r.end
            from total t, commRange r
            where t.comm = r.comm and
                t.loc between r.start and r.end and
                t.loc != t.new
        ')

On Tue, Nov 8, 2011 at 11:43 AM, Ben quant <ccqu...@gmail.com> wrote:
> Hello,
>
> I'm using package RpgSQL. Is there a better way to create a multi-line
> query/character string? I'm looking for less to type and readability.
>
> This is not very readable for large queries:
> s <-  'create table r.BOD("id" int primary key,"name" varchar(12))'
>
> I write a lot of code, so I'm looking to type less than this, but it is
> more readable from and SQL standpoint:
> s <- gsub("\n", "", 'create table r.BOD(
> "id" int primary key
> ,"name" varchar(12))
> ')
>
> How it is used:
> dbSendUpdate(con, s)
>
> Regards,
>
> Ben
>
>        [[alternative HTML version deleted]]
>
> ______________________________________________
> R-help@r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.
>



-- 
Jim Holtman
Data Munger Guru

What is the problem that you are trying to solve?
Tell me what you want to do, not how you want to do it.

______________________________________________
R-help@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.

Reply via email to