On Wed, Nov 12, 2014 at 06:48:18PM +0000, Gary Hook wrote: > - return qemu_ftell(f) - last_ftell; > + delta_ftell = qemu_ftell(f) - last_ftell; > + return( (delta_ftell > 0) ? 1 : (delta_ftell < 0) ? -1 : 0 );
Good find!
Please don't nest the ternary operator, it is hard to read.
if (delta_ftell < 0) {
return -1;
} else if (delta_ftell > 0) {
return 1;
} else {
return 0;
}
pgpofbJ1zW16y.pgp
Description: PGP signature
