- src/native/linux/opengl/extgl_glx.c dlopen should just use dlopen("libGL.so", ...) rather than forcing a specific version, otherwise this needs manual changes every time the version is bumped in X
- ARCH is an internal variable and shouldn't be overridden, it should be OK to just use another name for this and add it to SUBST_VARS - minor nit (and I know nobody has done one in ages) but it's easier for bulk ports sweeps if WANTLIB is right next to PERMIT_* - platform_build/bsd_ant/build.xml has some hardcoded /usr/X11R6 and /usr/local in library/header paths which should use ${LOCALBASE} / ${X11BASE}, either via a patch and SUBST_CMD, or just perl -pi -e s,/usr/X11R6,${X11BASE}, - GL should be listed in WANTLIB, along with a comment pointing out that it is dlopen()d so that people don't remove it in an overzealous ports sweep