On 2012-01-06, Pavel Korovin <[email protected]> wrote:
> Unfortunately I was unable to simplify the Makefile diff.

Sure you can.

+.if !${BUILD_PACKAGES:M-pgsql}
+BUILD_PACKAGES := ${BUILD_PACKAGES:N-pgsql}
+.endif

I don't know where you got this and a bunch of similar lines
but they do nothing useful.

> Although
> people are supposed to use binary packages, I'm modestly taking the
> view that it's the matter of taste. Ports now have a wonderful
> mechanism of PSEUDO_FLAVORS, why not use it?

Ports have had pseudo flavours for ages. It complicates testing and
makes the Makefile harder to read. Sometimes it is useful enough that
it's worth the extra pain. Sure, let some of the bigger stuff have a
switch. But rrdtool? dbi? what's the point?

> I moved all this "non-official" stuff into a single patch and added
> additional PACKAGE/PSEUDO_FLAVOR for it.

I don't see this. Wrong diff attached? Sounds nasty though, the issue
with adding any more intrusive unofficial patches to any port is that
it can really get in the way of updates, hiding them behind a switch
doesn't change this.

And the more options you have, the more things have to be tested
*each update*.


Reply via email to