davidedmundson added inline comments.

INLINE COMMENTS

> main.qml:130
> +                    (pagerModel.currentPage + 1) % repeater.count : 
> pagerModel.currentPage + 1;
> +                if (nextPage >= repeater.count) nextPage = repeater.count - 
> 1;
> +                pagerModel.changePage(nextPage);

would

  var nextPage = plasmoid.configuration.wrapPage?
                    (pagerModel.currentPage + 1) % repeater.count :
                     Math.max(pagerModel.currentPage + 1, repeater.count)

be more readable?

REPOSITORY
  R119 Plasma Desktop

REVISION DETAIL
  https://phabricator.kde.org/D14988

To: phuongn, #plasma, #vdg
Cc: davidedmundson, broulik, plasma-devel, ragreen, Pitel, ZrenBot, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, mart

Reply via email to