davidedmundson added a comment.
Thanks for looking into this.. first round of comments. INLINE COMMENTS > Notifications.qml:243 > } > - onPopupShown: notificationsRoot.popupShown(popup) > + //onPopupShown: notificationsRoot.popupShown(popup) > } ? > Notifications.qml:257 > + model: notificationsHistoryModel > + delegate: NotificationHistoryDelegate {} > + } How does this differ to the persistent delegate? Can we share most of this? > main.qml:56 > //notifications + jobs > property int totalCount: (notifications ? notifications.count : 0) + > (jobs ? jobs.count : 0) > + property int historyCount: totalCount + (notifications ? > notifications.historyCount : 0) This is now a somewhat confusing name as it's not the total. Then you have the real total under a new name property below. REPOSITORY R120 Plasma Workspace REVISION DETAIL https://phabricator.kde.org/D7271 To: progwolff, #plasma Cc: davidedmundson, plasma-devel, ZrenBot, progwolff, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, mart, lukas