hpereiradacosta added inline comments. INLINE COMMENTS
> oxygenanimations.cpp:178 > // unregister all toolbuttons that belong to a toolbar > - foreach( QWidget* widget, > _widgetStateEngine->registeredWidgets( AnimationHover|AnimationFocus ) ) > + foreach( QWidget* widget, > _widgetStateEngine->registeredWidgets( AnimationMode( > AnimationHover|AnimationFocus ) ) ) > { Looking further into the patch I get more confused. The argument taken by the Oxygen::WidgetStateEngine::registerWidget() (or registeredWidgets() is "Oxygen::AnimationModes" (with an "s"), and not "AnimationMode" The latter is defined via the macros Q_DECLARE_FLAGS(AnimationModes, AnimationMode) and Q_DECLARE_OPERATORS_FOR_FLAGS( Oxygen::AnimationModes ); My understanding was that this would allow AnimationsModes to be bitwise or (or and, or any operator) of the AnimationMode enum. Maybe these macros are now broken. In any case, at the minimum the correct syntax should be "AnimationModes(AnimationHover|AnimationFocus). Right ? REPOSITORY R113 Oxygen Theme REVISION DETAIL https://phabricator.kde.org/D5002 To: cfeck, hpereiradacosta Cc: plasma-devel, progwolff, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol