----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: http://svn.reviewboard.kde.org/r/5355/ -----------------------------------------------------------
(Updated 2010-09-24 23:59:14.824625) Review request for Plasma. Changes ------- Updated diff using post-review Summary ------- * Make configAccepted() just write the new config, and make configChanged() conditionally update the plasmoid after reading the config back in. * Split the grid resizing logic into its own method: recalculateGridSizes(int rows), and make it detect more edge cases. * Rename the main size calculation method to updateSizes(bool allowResize), which will resize the applet to its preferred size if allowResize is true. * Fix a bug which caused applet resizes to be wrongly cancelled in some situations. * Code style cleanups, remove unused variables, etc. (Sorry for putting so many changes into one patch) This addresses bug 250756. https://bugs.kde.org/show_bug.cgi?id=250756 Diffs (updated) ----- /trunk/KDE/kdebase/workspace/plasma/desktop/applets/pager/pager.h 1179262 /trunk/KDE/kdebase/workspace/plasma/desktop/applets/pager/pager.cpp 1179262 Diff: http://svn.reviewboard.kde.org/r/5355/diff Testing ------- Tested configuring the pager from the config interface and the desktop console, and that it responds correctly to changes in desktop count, and in FormFactor and size. Thanks, Anthony
_______________________________________________ Plasma-devel mailing list Plasma-devel@kde.org https://mail.kde.org/mailman/listinfo/plasma-devel