davidedmundson added a comment.
It's an SNI, I thought the systemtray could already filter SNIs in the enties tab of the system tray? ---- > I made different attempts to achieve this. The class was imagined like a singleton, but it's not really a singleton, anyway it's initialized by the volume applet and it stays there having only one instance. The class was a singleton within the given QML context, The configuration UI is another context, which is why it instantiated a new one. ---- One major comment about the config that I don't understand. INLINE COMMENTS > ConfigGeneral.qml:114 > + Kirigami.FormData.label: i18n("Show an indicator when an application > is using the:") > + checked: micIndicator.enabled > + text: i18n("Microphone") I don't see why we're doing this. Firstly it's a bit messy with regards to when this binds and updates vs when kcfg overwrites this binding. Secondly and much more importantly why should whether this is currently enabled or not ultimately change the config value stored of whether we show the indicator when something is recording? Once that's gone the entire singleton aspect is a lot less relevant. > microphoneindicator.cpp:320 > + > +void MicrophoneIndicatorInterface::setStatus(bool status) > +{ setStatus(bool) is confusing naming REPOSITORY R115 Plasma Audio Volume Applet REVISION DETAIL https://phabricator.kde.org/D29827 To: kurmikon, ngraham, #vdg, #plasma Cc: davidedmundson, meven, bcooksley, ngraham, plasma-devel, Orage, LeGast00n, The-Feren-OS-Dev, cblack, jraleigh, zachus, fbampaloukas, ragreen, ZrenBot, himcesjf, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, ahiemstra, mart