mart added inline comments. INLINE COMMENTS
> ksysguard_iface.xml:23 > + <method name="sensors"> > + <arg name="sensorsIds" type="as" direction="in"/> > + <arg name ="sensorInfo" type="a{s(sssuuddi)}" direction="out"/> since this is array in/array out, could consistence of naming be improved? either sensorsIds/sensorsInfos or sensorIds/sensorInfos > ksysguarddaemon.cpp:58 > + auto timer = new QTimer(this); > + timer->setInterval(500); > + connect(timer, &QTimer::timeout, this, &KSysGuardDaemon::sendFrame); needs to be always polling every half a second? could it be somewhat adjustable (maybe depending on ac/on battery?) > ksysguarddaemon.cpp:86 > + > + if(pluginObjects.isEmpty()) { > + qWarning() << "No plugins found"; if ( > main.cpp:1 > +#include <QCoreApplication> > +#include <QDebug> copyright? > main.cpp:57 > + > + //TODO human readable flag > + //we then get the relevant sensorInfo for what we subscribe to and cache > that what's the commandline option missing? > AggregateSensor.cpp:199 > + m_dataChangeQueued = true; > + QTimer::singleShot(m_dataCompressionDuration, [this]() { > + Q_EMIT valueChanged(); if this timer is needed for compression, shouldn't be the same timer always restarted? if i call singleshot 10 times, iirc that slot will be invoked delayed 10 times > ksgrdiface.cpp:185 > + auto type = newSensorInfo.at(1); > + if (type == QLatin1String("logfile")) > + continue; // logfile data type not currently supported if () { } > ksgrdiface.cpp:378 > +{ > + // TODO: This is pretty ugly, but it is really hard to add this > information to ksysguardd. > + // So for now, we just map sensor ids to short names and return that. maybe mapping on a config file? REPOSITORY R106 KSysguard REVISION DETAIL https://phabricator.kde.org/D28333 To: davidedmundson, #plasma Cc: mart, zzag, plasma-devel, Orage, LeGast00n, The-Feren-OS-Dev, cblack, jraleigh, zachus, fbampaloukas, ragreen, ZrenBot, ngraham, himcesjf, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, ahiemstra