broulik added inline comments. INLINE COMMENTS
> main.xml:15 > <label>length in pixels of the spacer. Configuration effective only > if expanding is set to false.</label> > + <default>-1</default> > </entry> Please mention in the label what `-1` means > main.qml:30 > + > + z: 9999 > + property bool horizontal: plasmoid.formFactor !== > PlasmaCore.Types.Vertical Why that? > main.qml:68 > + action.checkable = true; > + action.checked = plasmoid.configuration.expanding; > + Could be a `Qt.binding`? > main.qml:77 > + // Every time this binding gets reevaluated we want to queue a > recomputation of the size hints > + relayoutTimer.restart(); > + if (!twinSpacer || !panelLayout || !leftTwin || !rightTwin) { Does `Qt.callLater(foo)` work? It also compresses subsequent calls to the same method (i.e. doesn't work with a closure) > main.qml:95 > + for (var i in panelLayout.children) { > + if (!panelLayout.children[i].visible) { > + continue; Please cache `panelLayout.children[i]` in a variable to make the code below somewhat more readable REPOSITORY R120 Plasma Workspace REVISION DETAIL https://phabricator.kde.org/D27481 To: mart, #plasma, #vdg Cc: broulik, ngraham, plasma-devel, Orage, LeGast00n, The-Feren-OS-Dev, cblack, jraleigh, zachus, fbampaloukas, GB_2, ragreen, ZrenBot, alexeymin, himcesjf, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, ahiemstra, mart