ervin requested changes to this revision. ervin added a comment. This revision now requires changes to proceed.
Almost there. INLINE COMMENTS > componentchooserfilemanager.cpp:41 > > +QRadioButton * findDolphinRadio(QList<QRadioButton *> dynamicRadioButtons) { > + auto it = std::find_if(dynamicRadioButtons.begin(), > dynamicRadioButtons.end(), [=](QRadioButton *radio) { Please move it before the ctor an declare it in the anonymous namespace ("namespace { ... }"). Also remove the space after the * and receive the radio buttons list as a const reference not by value. Nitpick: I think I'd rename the parameter to something like "radioButtons" or "radioButtonList". > componentchooserfilemanager.h:46 > private: > + QRadioButton* findDolphinRadio() const; > + This change should go away now. REPOSITORY R119 Plasma Desktop REVISION DETAIL https://phabricator.kde.org/D26324 To: meven, ervin, #plasma Cc: plasma-devel, LeGast00n, The-Feren-OS-Dev, jraleigh, zachus, fbampaloukas, GB_2, ragreen, ZrenBot, ngraham, alexeymin, himcesjf, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, ahiemstra, mart