broulik added a comment.

  You might want to split that into a proper if statement otherwise it becomes 
somewhat hard to read. Something like
  
    source: {
        if (taskIcon.status === PlasmaCore.Types.NeedsAttentionStatus && 
(AttentionIcon || AttentionIconName)) {
            return AttentionIcon || AttentionIconName;
        }
        return Icon || IconName;
    }

REPOSITORY
  R120 Plasma Workspace

BRANCH
  master

REVISION DETAIL
  https://phabricator.kde.org/D24865

To: kmaterka, #plasma, broulik, #plasma_workspaces
Cc: lbeltrame, plasma-devel, LeGast00n, The-Feren-OS-Dev, jraleigh, 
fbampaloukas, GB_2, ragreen, ZrenBot, ngraham, alexeymin, himcesjf, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, ahiemstra, mart

Reply via email to