> On 2009-10-19 21:27:14, Aaron Seigo wrote: > > /trunk/KDE/kdelibs/plasma/toolbox.h, lines 71-72 > > <http://reviewboard.kde.org/r/1861/diff/2/?file=12911#file12911line71> > > > > this is actually a pretty poor name that we've kept only because it's > > an internal API ;) > > > > it can also be an edge ... setLocation would be the "natural" name imho > > ... maybe the corner values should be add to Plasma::Location and that enum > > used?
not sure, it would be possible to do setLocation(TopLeft) to a containment, what would happen in this situation? what about still keeping it private?(it would make the code in containment.cpp a bit uglier but i think it could easily be avoided being exported) in the netbok for instance i support only the top left bottom etc locations, so it seems sensible it's totally managed by subclasses? - Marco ----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: http://reviewboard.kde.org/r/1861/#review2720 ----------------------------------------------------------- On 2009-10-17 21:48:21, Marco Martin wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > http://reviewboard.kde.org/r/1861/ > ----------------------------------------------------------- > > (Updated 2009-10-17 21:48:21) > > > Review request for Plasma. > > > Summary > ------- > > this adds a setToolboxItem function. > it makes possible for the openToolBox() function to work if the containment > totally manages the toolbox by itself. > it uses a "showing" property that custom toolboxes should implement to > show/hide the toolbox > > > Diffs > ----- > > /trunk/KDE/kdelibs/plasma/CMakeLists.txt 1036057 > /trunk/KDE/kdelibs/plasma/applet.cpp 1036057 > /trunk/KDE/kdelibs/plasma/containment.h 1036057 > /trunk/KDE/kdelibs/plasma/containment.cpp 1036057 > /trunk/KDE/kdelibs/plasma/private/desktoptoolbox.cpp 1036057 > /trunk/KDE/kdelibs/plasma/private/desktoptoolbox_p.h 1036057 > /trunk/KDE/kdelibs/plasma/private/paneltoolbox.cpp 1036057 > /trunk/KDE/kdelibs/plasma/private/paneltoolbox_p.h 1036057 > /trunk/KDE/kdelibs/plasma/private/toolbox.cpp 1036057 > /trunk/KDE/kdelibs/plasma/private/toolbox_p.h 1036057 > /trunk/KDE/kdelibs/plasma/toolbox.h PRE-CREATION > /trunk/KDE/kdelibs/plasma/toolbox.cpp PRE-CREATION > > Diff: http://reviewboard.kde.org/r/1861/diff > > > Testing > ------- > > > Thanks, > > Marco > > _______________________________________________ Plasma-devel mailing list Plasma-devel@kde.org https://mail.kde.org/mailman/listinfo/plasma-devel