> the code isn't any shorter, but now there's a bunch of hash insertions and > lookups? hm. i don't think this wins anything but (negligibly) slower code > and (negligibly) increased memory usage. it's not so bad as to revert it > or anything, but it's not really an improvement to the code and isn't a > pattern that should extend into other krunner code imho. Maybe, if I've got a lot of time, I'll revert it, ok? > one thing that should be improved, however, is the reading/writing of > values from/to the config object. right now the string "com_quit" appears > in two different files, once to read it and once to write it. that's an > approach just asking for annoying errors :) instead, i'd recommend: > > static const char * CONFIG_QUIT "com_quit"; > > (or whatever you prefer to call it) in a header somewhere and then use > CONFIG_QUIT (or whatever) in the code. that limits the "magic" string to > just one location and lets the compiler complain when you misspell it one > of the two files ;) I haven't got so much time at the moment, but I'll try to implement it, when I've got time again.
> speaking of misspellings, it's "increase" and "decrease" not "incrase" and > "decrase" :) Oh, I will correct it, I'm German and I didn't know the words before, sorry. Thanks, Jan _______________________________________________ Plasma-devel mailing list Plasma-devel@kde.org https://mail.kde.org/mailman/listinfo/plasma-devel