From: Sven Eckelmann <s...@narfation.org>

The chain pointer was already created in batadv_frag_purge_orig to make the
checks more readable. Just use the chain pointer everywhere instead of
having the same dereference + array access in the most lines of this
function.

Signed-off-by: Sven Eckelmann <s...@narfation.org>
Acked-by: Martin Hundebøll <mar...@hundeboll.net>
Signed-off-by: Marek Lindner <mareklind...@neomailbox.ch>
Signed-off-by: Antonio Quartulli <anto...@meshcoding.com>
---
 net/batman-adv/fragmentation.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/net/batman-adv/fragmentation.c b/net/batman-adv/fragmentation.c
index 700c96c..20d9282 100644
--- a/net/batman-adv/fragmentation.c
+++ b/net/batman-adv/fragmentation.c
@@ -71,14 +71,14 @@ void batadv_frag_purge_orig(struct batadv_orig_node 
*orig_node,
 
        for (i = 0; i < BATADV_FRAG_BUFFER_COUNT; i++) {
                chain = &orig_node->fragments[i];
-               spin_lock_bh(&orig_node->fragments[i].lock);
+               spin_lock_bh(&chain->lock);
 
                if (!check_cb || check_cb(chain)) {
-                       batadv_frag_clear_chain(&orig_node->fragments[i].head);
-                       orig_node->fragments[i].size = 0;
+                       batadv_frag_clear_chain(&chain->head);
+                       chain->size = 0;
                }
 
-               spin_unlock_bh(&orig_node->fragments[i].lock);
+               spin_unlock_bh(&chain->lock);
        }
 }
 
-- 
2.6.4

--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to