On Tue, Sep 22, 2015 at 6:53 AM, Jiri Pirko <j...@resnulli.us> wrote: > From: Jiri Pirko <j...@mellanox.com> > > Jiri Pirko (10): > switchdev: rename "trans" to "trans_ph". > switchdev: introduce transaction item queue for attr_set and obj_add > switchdev: move transaction phase enum under transaction structure > switchdev: add switchdev_trans_ph_prepare/commit helpers > rocker: push struct switchdev_trans down through rocker code > rocker: use switchdev transaction queue for allocated memory > switchdev: remove "NONE" transaction phase > switchdev: remove "ABORT" transaction phase > dsa: use prepare/commit switchdev transaction helpers > switchdev: reduce transaction phase enum down to a boolean > > drivers/net/ethernet/rocker/rocker.c | 311 > +++++++++++++++-------------------- > include/net/switchdev.h | 40 +++-- > net/dsa/slave.c | 31 ++-- > net/switchdev/switchdev.c | 99 ++++++++--- > 4 files changed, 252 insertions(+), 229 deletions(-)
I like this version much better! Thank you for making the adjustments. My main concern about easily opting-out of prepare phase is gone. And I appreciate that you moved trans * as arg to attr_set and obj_add. Would you add a write-up in switchdev.txt about prepare-commit model and how to use the transaction object? Add it to this patchset, if you can. What testing have you done? I'll do testing today on my bench and report back, but I kind of want to know what to expect. Give a day or two for testing and review. -- To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html