Jiri Pirko (6):
  switchdev: rename "trans" to "trans_ph".
  switchdev: introduce transaction infrastructure for attr_set and
    obj_add
  rocker: switch to local transaction phase enum
  switchdev: move transaction phase enum under transaction structure
  rocker: use switchdev transaction queue for allocated memory
  switchdev: split commit and prepare phase into two callbacks

 drivers/net/ethernet/rocker/rocker.c | 579 ++++++++++++++++++-----------------
 include/net/switchdev.h              |  39 ++-
 net/dsa/slave.c                      | 129 +++++---
 net/switchdev/switchdev.c            | 153 +++++++--
 4 files changed, 545 insertions(+), 355 deletions(-)

-- 
1.9.3

--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to