On 4/21/15 10:05 PM, Cong Wang wrote:
On Tue, Apr 21, 2015 at 12:27 PM, Alexei Starovoitov <a...@plumgrid.com> wrote:
introduce tc_classify_act() and qdisc_drop_bypass() helper functions to reduce
copy-paste among different qdiscs


I don't think qdisc_drop_bypass() is more readable than without it,
maybe you need a better name, or just leave the code as it is.

what would be a better name? I'm open to suggestions.

We already have qdisc_drop() that does:
        kfree_skb(skb);
        qdisc_qstats_drop(sch);

my proposed qdisc_drop_bypass() does stats math conditionally:
        if (err & __NET_XMIT_BYPASS)
                qdisc_qstats_drop(sch);
        kfree_skb(skb);

So together I think they fit nicely. With this helper the sch_choke.c
looks like:
congestion_drop:
        qdisc_drop(skb, sch);
        return NET_XMIT_CN;
other_drop:
        qdisc_drop_bypass(skb, sch, ret);
        return ret;

and in the next set of cleanups I'm planning to combine these two
helpers into one, but I need to cleanup __NET_XMIT_BYPASS flag first.

--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to