On Fri, 05 Oct 2007 17:14:31 -0400 Jeff Garzik <[EMAIL PROTECTED]> wrote:
> David Miller wrote: > > From: Stephen Hemminger <[EMAIL PROTECTED]> > > Date: Fri, 5 Oct 2007 08:40:36 -0700 > > > >> WARNING: braces {} are not necessary for single statement blocks > >> #691: FILE: drivers/net/niu.c:603: > >> + if (lp->loopback_mode == LOOPBACK_PHY) { > >> + test_cfg_val |= ((ENET_TEST_MD_PAD_LOOPBACK << > >> + ENET_SERDES_TEST_MD_0_SHIFT) | > >> + (ENET_TEST_MD_PAD_LOOPBACK << > >> + ENET_SERDES_TEST_MD_1_SHIFT) | > >> + (ENET_TEST_MD_PAD_LOOPBACK << > >> + ENET_SERDES_TEST_MD_2_SHIFT) | > >> + (ENET_TEST_MD_PAD_LOOPBACK << > >> + ENET_SERDES_TEST_MD_3_SHIFT)); > >> + } > > > > This is why I don't run checkpatch on my work. > > IMO it -is- useful. > > You just have to ignore some of its complaints. Part of my coding style > includes the multiple assignment thing that checkpatch complains about: > > status = > msi->status = br32(QDMA_STAT); > > and I am not going to stop doing that just because checkpatch complains :) > > > > This statement is a "single statement" but it's broken up > > into multiple lines for readability, and it make perfect > > sense to put braces around this basic block so it's easier > > for humans to see what's going on. > > Strongly agreed. > > Jeff Agreed, don't turn into a bot. All it's complaints don't have to be fixed, same goes for sparse. It just helps catch unintentional cruft. -- Stephen Hemminger <[EMAIL PROTECTED]> - To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html