On Thu, Mar 18, 2021 at 09:21:08PM -0700, Andrii Nakryiko wrote: > > --- /dev/null > > +++ b/tools/testing/selftests/bpf/prog_tests/kfunc_call.c > > @@ -0,0 +1,61 @@ > > +// SPDX-License-Identifier: GPL-2.0 > > +/* Copyright (c) 2021 Facebook */ > > +#include <test_progs.h> > > +#include <network_helpers.h> > > +#include "kfunc_call_test.skel.h" > > +#include "kfunc_call_test_subprog.skel.h" > > + > > +static __u32 duration; > > + > > you shouldn't need it, you don't use CHECK()s It was for bpf_prog_test_run(). Just noticed it can take NULL. will remove in v2.
- [PATCH bpf-next 11/15] libbpf: Record extern sym relocat... Martin KaFai Lau
- Re: [PATCH bpf-next 11/15] libbpf: Record extern sy... Andrii Nakryiko
- [PATCH bpf-next 09/15] libbpf: Refactor codes for findin... Martin KaFai Lau
- Re: [PATCH bpf-next 09/15] libbpf: Refactor codes f... Andrii Nakryiko
- [PATCH bpf-next 12/15] libbpf: Support extern kernel fun... Martin KaFai Lau
- Re: [PATCH bpf-next 12/15] libbpf: Support extern k... Andrii Nakryiko
- Re: [PATCH bpf-next 12/15] libbpf: Support exte... Martin KaFai Lau
- [PATCH bpf-next 15/15] bpf: selftest: Add kfunc_call tes... Martin KaFai Lau
- Re: [PATCH bpf-next 15/15] bpf: selftest: Add kfunc... kernel test robot
- Re: [PATCH bpf-next 15/15] bpf: selftest: Add kfunc... Andrii Nakryiko
- Re: [PATCH bpf-next 15/15] bpf: selftest: Add k... Martin KaFai Lau
- [PATCH bpf-next 13/15] bpf: selftests: Rename bictcp to ... Martin KaFai Lau
- Re: [PATCH bpf-next 13/15] bpf: selftests: Rename b... Andrii Nakryiko
- [PATCH bpf-next 14/15] bpf: selftest: bpf_cubic and bpf_... Martin KaFai Lau
- Re: [PATCH bpf-next 14/15] bpf: selftest: bpf_cubic... Andrii Nakryiko