On Fri, Jan 29, 2021 at 2:29 AM Simon Horman <simon.hor...@netronome.com> wrote: > +/** > + * psched_ratecfg_precompute__() - Pre-compute values for reciprocal division > + * @rate: Rate to compute reciprocal division values of > + * @mult: Multiplier for reciprocal division > + * @shift: Shift for reciprocal division > + * > + * The multiplier and shift for reciprocal division by rate are stored > + * in mult and shift. > + * > + * The deal here is to replace a divide by a reciprocal one > + * in fast path (a reciprocal divide is a multiply and a shift) > + * > + * Normal formula would be : > + * time_in_ns = (NSEC_PER_SEC * len) / rate_bps > + * > + * We compute mult/shift to use instead : > + * time_in_ns = (len * mult) >> shift; > + * > + * We try to get the highest possible mult value for accuracy, > + * but have to make sure no overflows will ever happen. > + * > + * reciprocal_value() is not used here it doesn't handle 64-bit values. > + */ > +static void psched_ratecfg_precompute__(u64 rate, u32 *mult, u8 *shift)
Am I the only one who thinks "foo__()" is an odd name? We usually use "__foo()" for helper or unlocked version of "foo()". And, you probably want to move the function doc to its exported variant instead, right? Thanks.