On Fri, 9 Oct 2020 09:35:03 +0200 Eric Dumazet wrote: > On Fri, Oct 9, 2020 at 2:18 AM Jakub Kicinski <k...@kernel.org> wrote: > > > > On Wed, 7 Oct 2020 09:51:11 -0700 Eric Dumazet wrote: > > > diff --git a/include/net/sch_generic.h b/include/net/sch_generic.h > > > index > > > 6c762457122fd0091cb0f2bf41bda73babc4ac12..d8fd8676fc724110630904909f64d7789f3a4b47 > > > 100644 > > > --- a/include/net/sch_generic.h > > > +++ b/include/net/sch_generic.h > > > @@ -91,7 +91,7 @@ struct Qdisc { > > > struct net_rate_estimator __rcu *rate_est; > > > struct gnet_stats_basic_cpu __percpu *cpu_bstats; > > > struct gnet_stats_queue __percpu *cpu_qstats; > > > - int padded; > > > + int pad; > > > refcount_t refcnt; > > > > > > /* > > > > Hi Eric! > > > > Why keep the pad field? the member to lines down is > > __cacheline_aligned, so we shouldn't have to manually > > push things out? > > > > struct gnet_stats_queue __percpu *cpu_qstats; > > int pad; > > I usually prefer adding explicit fields to tell where the holes are, > for future reuse. > Not many developers are aware of pahole existence :/ > I renamed it to pad, I could have used padding or something else.
Alright then, applied, thank you!