Refactor and unify partner-TXQ handling in the EF100 and legacy drivers. The main thrust of this series is to remove from the legacy (Siena/EF10) driver the assumption that a netdev TX queue has precisely two hardware TXQs (checksummed and unchecksummed) associated with it, so that in future we can have more (e.g. for handling inner-header checksums) or fewer (e.g. to free up hardware queues for XDP usage).
Changes from v1: * better explain patch #1 in the commit message, and rename xmit_more_available to xmit_pending * add new patch #2 applying the same approach to ef100, for consistency Edward Cree (6): sfc: add and use efx_tx_send_pending in tx.c sfc: make ef100 xmit_more handling look more like ef10's sfc: use tx_queue->old_read_count in EF100 TX path sfc: use efx_channel_tx_[old_]fill_level() in Siena/EF10 TX datapath sfc: rewrite efx_tx_may_pio sfc: remove efx_tx_queue_partner drivers/net/ethernet/sfc/ef10.c | 2 +- drivers/net/ethernet/sfc/ef100_tx.c | 34 +++++---- drivers/net/ethernet/sfc/ef100_tx.h | 1 - drivers/net/ethernet/sfc/farch.c | 2 +- drivers/net/ethernet/sfc/net_driver.h | 22 ++++-- drivers/net/ethernet/sfc/nic_common.h | 40 +---------- drivers/net/ethernet/sfc/tx.c | 99 +++++++++++++++++---------- drivers/net/ethernet/sfc/tx_common.c | 9 +-- 8 files changed, 104 insertions(+), 105 deletions(-)