Hi Dave, Jakub, This series contains small misc updates to mlx5 driver.
Note that the pci relaxed ordering patch is now much smaller and without the driver private knob by following the discussion conclusions on the previous patch to only use the pcie_relaxed_ordering_enabled() kernel helper, and setpci to disable it as a chicken bit. For more information please see tag log below. Please pull and let me know if there is any problem. Thanks, Saeed. --- The following changes since commit 5e619d73e6797ed9f2554a1bf996d52d8c91ca50: net/mlx4: Use fallthrough pseudo-keyword (2020-07-27 13:14:10 -0700) are available in the Git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/saeed/linux.git tags/mlx5-updates-2020-07-28 for you to fetch changes up to 22f9d2f4ee810e6442185ba7ecab37e24de1b413: net/mlx5: drop unnecessary list_empty (2020-07-28 02:37:57 -0700) ---------------------------------------------------------------- mlx5-updates-2020-07-28 Misc and small update to mlx5 driver: 1) Aya adds PCIe relaxed ordering support for mlx5 netdev queues. 2) Eran Refactors pages data base to be per vf/function to speedup unload time. 3) Parav changes eswitch steering initialization to account for tota_vports rather than for only active vports and Link non uplink representors to PCI device, for uniform naming scheme. 4) Tariq, trivial RX code improvements and missing inidirect calls wrappers. 5) Small cleanup patches ---------------------------------------------------------------- Alex Vesker (1): net/mlx5: DR, Reduce print level for matcher print Avihu Hagag (1): net/mlx5: Add function ID to reclaim pages debug log Aya Levin (1): net/mlx5e: Add support for PCI relaxed ordering Eran Ben Elisha (1): net/mlx5: Hold pages RB tree per VF Gustavo A. R. Silva (1): net/mlx5: Use fallthrough pseudo-keyword Julia Lawall (1): net/mlx5: drop unnecessary list_empty Parav Pandit (4): net/mlx5: E-switch, Consider maximum vf vports for steering init net/mlx5: E-switch, Reuse total_vports and avoid duplicate nvports net/mlx5: E-switch, Use eswitch total_vports net/mlx5e: Link non uplink representors to PCI device Tariq Toukan (3): net/mlx5e: RX, Re-work initializaiton of RX function pointers net/mlx5e: Move exposure of datapath function to txrx header net/mlx5e: Use indirect call wrappers for RX post WQEs functions drivers/net/ethernet/mellanox/mlx5/core/en.h | 55 ++------ drivers/net/ethernet/mellanox/mlx5/core/en/txrx.h | 30 ++++- drivers/net/ethernet/mellanox/mlx5/core/en/xdp.c | 5 +- .../net/ethernet/mellanox/mlx5/core/en/xsk/setup.c | 1 + .../net/ethernet/mellanox/mlx5/core/en/xsk/tx.c | 1 - .../mellanox/mlx5/core/en_accel/ipsec_rxtx.h | 1 - .../ethernet/mellanox/mlx5/core/en_accel/ktls_tx.c | 2 +- .../net/ethernet/mellanox/mlx5/core/en_common.c | 12 +- .../net/ethernet/mellanox/mlx5/core/en_ethtool.c | 2 +- drivers/net/ethernet/mellanox/mlx5/core/en_main.c | 55 +------- drivers/net/ethernet/mellanox/mlx5/core/en_rep.c | 9 +- drivers/net/ethernet/mellanox/mlx5/core/en_rep.h | 6 +- drivers/net/ethernet/mellanox/mlx5/core/en_rx.c | 109 +++++++++++++--- drivers/net/ethernet/mellanox/mlx5/core/en_txrx.c | 2 +- drivers/net/ethernet/mellanox/mlx5/core/eswitch.h | 1 - .../ethernet/mellanox/mlx5/core/eswitch_offloads.c | 35 ++--- .../net/ethernet/mellanox/mlx5/core/fpga/conn.c | 4 +- .../net/ethernet/mellanox/mlx5/core/ipoib/ipoib.c | 3 +- .../net/ethernet/mellanox/mlx5/core/ipoib/ipoib.h | 2 +- .../ethernet/mellanox/mlx5/core/ipoib/ipoib_vlan.c | 3 +- drivers/net/ethernet/mellanox/mlx5/core/lag_mp.c | 8 +- .../net/ethernet/mellanox/mlx5/core/pagealloc.c | 145 +++++++++++++++------ .../mellanox/mlx5/core/steering/dr_matcher.c | 15 +-- .../ethernet/mellanox/mlx5/core/steering/dr_rule.c | 5 +- drivers/net/ethernet/mellanox/mlx5/core/vport.c | 2 +- include/linux/mlx5/driver.h | 2 +- 26 files changed, 302 insertions(+), 213 deletions(-)