Make use of the struct_size() helper instead of an open-coded version
in order to avoid any potential type mistakes. Also, remove unnecessary
variable _size_.

This code was detected with the help of Coccinelle and, audited and
fixed manually.

Addresses-KSPP-ID: https://github.com/KSPP/linux/issues/83
Signed-off-by: Gustavo A. R. Silva <gustavo...@kernel.org>
---
 drivers/net/ethernet/ti/am65-cpsw-qos.c | 8 +++-----
 1 file changed, 3 insertions(+), 5 deletions(-)

diff --git a/drivers/net/ethernet/ti/am65-cpsw-qos.c 
b/drivers/net/ethernet/ti/am65-cpsw-qos.c
index 32eac04468bb..3bdd4dbcd2ff 100644
--- a/drivers/net/ethernet/ti/am65-cpsw-qos.c
+++ b/drivers/net/ethernet/ti/am65-cpsw-qos.c
@@ -505,7 +505,6 @@ static int am65_cpsw_set_taprio(struct net_device *ndev, 
void *type_data)
        struct am65_cpsw_port *port = am65_ndev_to_port(ndev);
        struct tc_taprio_qopt_offload *taprio = type_data;
        struct am65_cpsw_est *est_new;
-       size_t size;
        int ret = 0;
 
        if (taprio->cycle_time_extension) {
@@ -513,10 +512,9 @@ static int am65_cpsw_set_taprio(struct net_device *ndev, 
void *type_data)
                return -EOPNOTSUPP;
        }
 
-       size = sizeof(struct tc_taprio_sched_entry) * taprio->num_entries +
-              sizeof(struct am65_cpsw_est);
-
-       est_new = devm_kzalloc(&ndev->dev, size, GFP_KERNEL);
+       est_new = devm_kzalloc(&ndev->dev,
+                              struct_size(est_new, taprio.entries, 
taprio->num_entries),
+                              GFP_KERNEL);
        if (!est_new)
                return -ENOMEM;
 
-- 
2.27.0

Reply via email to