This series adds HWMON support for the temperature sensor and the related alarms on the 107/108/109 chips.
v2: - remove struct aqr_priv - rename header file to aquantia.h v3: - add conditional compiling of aquantia_hwmon.c - improve converting sensor register values to/from long - add helper aqr_hwmon_test_bit Heiner Kallweit (2): net: phy: aquantia: rename aquantia.c to aquantia_main.c net: phy: aquantia: add hwmon support drivers/net/phy/Makefile | 4 + drivers/net/phy/aquantia.h | 16 ++ drivers/net/phy/aquantia_hwmon.c | 250 ++++++++++++++++++ .../net/phy/{aquantia.c => aquantia_main.c} | 4 + 4 files changed, 274 insertions(+) create mode 100644 drivers/net/phy/aquantia.h create mode 100644 drivers/net/phy/aquantia_hwmon.c rename drivers/net/phy/{aquantia.c => aquantia_main.c} (99%) -- 2.20.1