On 17.02.2019 05:18, Andrew Lunn wrote: > On Sat, Feb 16, 2019 at 06:44:24PM -0800, Florian Fainelli wrote: >> >> >> On 2/16/2019 11:51 AM, Heiner Kallweit wrote: >>> From: Andrew Lunn <and...@lunn.ch> >>> C45 configuration of 10/100 and multi-giga bit auto negotiation >>> advertisement is standardized. Configuration of 1000Base-T however >>> appears to be vendor specific. Move the generic code out of the >>> Marvell driver into the common phy-c45.c file. >>> >>> Signed-off-by: Andrew Lunn <and...@lunn.ch> >>> [hkallwe...@gmail.com: use new helper linkmode_adv_to_mii_10gbt_adv_t and >>> split patch] >>> Signed-off-by: Heiner Kallweit <hkallwe...@gmail.com> >>> --- >>> drivers/net/phy/phy-c45.c | 44 +++++++++++++++++++++++++++++++++++++++ >>> include/linux/phy.h | 1 + >>> 2 files changed, 45 insertions(+) >>> >>> diff --git a/drivers/net/phy/phy-c45.c b/drivers/net/phy/phy-c45.c >>> index 0374c50b1..bea1b0c6e 100644 >>> --- a/drivers/net/phy/phy-c45.c >>> +++ b/drivers/net/phy/phy-c45.c >>> @@ -78,6 +78,50 @@ int genphy_c45_pma_setup_forced(struct phy_device >>> *phydev) >>> } >>> EXPORT_SYMBOL_GPL(genphy_c45_pma_setup_forced); >>> >>> +/** >>> + * genphy_c45_an_config_an - configure advertisement registers >> >> Nit: are not the two "an" redundant" here? Unless the first one means >> something different in which case naming this: >> genphy_c45_an_config_aneg() would be clearer? > > Hi Florian > > Heiner and I had a brief discussion about this. There is a general > trend in the naming to have the device name in the function name. So > genphy_c45_pma_setup_forced uses the PMA device registers, > genphy_c45_an_disable_aneg uses the AN device registers, etc. > > However, genphy_c45_an_config_aneg() might be better. > Good, then I'll prepare an update with the changed name.
> Andrew > Heiner