On Thu, Jan 31, 2019 at 11:07 AM Daniel Borkmann <dan...@iogearbox.net> wrote: > > On 01/29/2019 04:12 PM, Magnus Karlsson wrote: > > Move the pr_*() functions in libbpf.c to a common header file called > > libbpf_internal.h. This so that the later libbpf AF_XDP helper library > > code in xsk.c can use these printing functions too. > > > > Signed-off-by: Magnus Karlsson <magnus.karls...@intel.com> > > --- > > tools/lib/bpf/libbpf.c | 30 +----------------------------- > > tools/lib/bpf/libbpf_internal.h | 41 > > +++++++++++++++++++++++++++++++++++++++++ > > 2 files changed, 42 insertions(+), 29 deletions(-) > > create mode 100644 tools/lib/bpf/libbpf_internal.h > > > > diff --git a/tools/lib/bpf/libbpf.c b/tools/lib/bpf/libbpf.c > > index 2ccde17..1d7fe26 100644 > > --- a/tools/lib/bpf/libbpf.c > > +++ b/tools/lib/bpf/libbpf.c > > @@ -39,6 +39,7 @@ > > #include <gelf.h> > > > > #include "libbpf.h" > > +#include "libbpf_internal.h" > > #include "bpf.h" > > #include "btf.h" > > #include "str_error.h" > > @@ -51,34 +52,6 @@ > > #define BPF_FS_MAGIC 0xcafe4a11 > > #endif > > > > -#define __printf(a, b) __attribute__((format(printf, a, b))) > > - > > -__printf(1, 2) > > -static int __base_pr(const char *format, ...) > > -{ > > - va_list args; > > - int err; > > - > > - va_start(args, format); > > - err = vfprintf(stderr, format, args); > > - va_end(args); > > - return err; > > -} > > - > > -static __printf(1, 2) libbpf_print_fn_t __pr_warning = __base_pr; > > -static __printf(1, 2) libbpf_print_fn_t __pr_info = __base_pr; > > -static __printf(1, 2) libbpf_print_fn_t __pr_debug; > > - > > -#define __pr(func, fmt, ...) \ > > -do { \ > > - if ((func)) \ > > - (func)("libbpf: " fmt, ##__VA_ARGS__); \ > > -} while (0) > > - > > -#define pr_warning(fmt, ...) __pr(__pr_warning, fmt, ##__VA_ARGS__) > > -#define pr_info(fmt, ...) __pr(__pr_info, fmt, ##__VA_ARGS__) > > -#define pr_debug(fmt, ...) __pr(__pr_debug, fmt, ##__VA_ARGS__) > > - > > void libbpf_set_print(libbpf_print_fn_t warn, > > libbpf_print_fn_t info, > > libbpf_print_fn_t debug) > > @@ -96,7 +69,6 @@ void libbpf_set_print(libbpf_print_fn_t warn, > > goto out; \ > > } while(0) > > > > - > > /* Copied from tools/perf/util/util.h */ > > #ifndef zfree > > # define zfree(ptr) ({ free(*ptr); *ptr = NULL; }) > > diff --git a/tools/lib/bpf/libbpf_internal.h > > b/tools/lib/bpf/libbpf_internal.h > > new file mode 100644 > > index 0000000..951c078 > > --- /dev/null > > +++ b/tools/lib/bpf/libbpf_internal.h > > Just really minor nit: lets name the header utils.h or such. It would also > make > sense to move the zfree() and zclose() to this and make use of it.
Will fix. Thanks: Magnus > > @@ -0,0 +1,41 @@ > > +/* SPDX-License-Identifier: (LGPL-2.1 OR BSD-2-Clause) */ > > + > > +/* > > + * Common internal libbpf functions and definitions. > > + * > > + * Copyright (C) 2013-2015 Alexei Starovoitov <a...@kernel.org> > > + * Copyright (C) 2015 Wang Nan <wangn...@huawei.com> > > + * Copyright (C) 2015 Huawei Inc. > > + */ > > +#ifndef __LIBBPF_LIBBPF_INTERNAL_H > > +#define __LIBBPF_LIBBPF_INTERNAL_H > > + > > +#define __printf(a, b) __attribute__((format(printf, a, b))) > > + > > +__printf(1, 2) > > +static int __base_pr(const char *format, ...) > > +{ > > + va_list args; > > + int err; > > + > > + va_start(args, format); > > + err = vfprintf(stderr, format, args); > > + va_end(args); > > + return err; > > +} > > + > > +static __maybe_unused __printf(1, 2) libbpf_print_fn_t __pr_warning = > > __base_pr; > > +static __maybe_unused __printf(1, 2) libbpf_print_fn_t __pr_info = > > __base_pr; > > +static __maybe_unused __printf(1, 2) libbpf_print_fn_t __pr_debug; > > + > > +#define __pr(func, fmt, ...) \ > > +do { \ > > + if ((func)) \ > > + (func)("libbpf: " fmt, ##__VA_ARGS__); \ > > +} while (0) > > + > > +#define pr_warning(fmt, ...) __pr(__pr_warning, fmt, ##__VA_ARGS__) > > +#define pr_info(fmt, ...) __pr(__pr_info, fmt, ##__VA_ARGS__) > > +#define pr_debug(fmt, ...) __pr(__pr_debug, fmt, ##__VA_ARGS__) > > + > > +#endif /* __LIBBPF_LIBBPF_INTERNAL_H */ > > >