On 1/30/19 2:46 PM, Andrew Lunn wrote: >> @@ -425,6 +425,8 @@ struct dsa_switch_ops { >> /* >> * Multicast database >> */ >> + int (*port_multicast_toggle)(struct dsa_switch *ds, int port, >> + bool mc_disabled); >> int (*port_mdb_prepare)(struct dsa_switch *ds, int port, >> const struct switchdev_obj_port_mdb *mdb); >> void (*port_mdb_add)(struct dsa_switch *ds, int port, > > Hi Florian > > I took a second look at this, after you asked the question. > > What i see above is that port_multicast_toggle is different to > port_mdb_prepare and port_mdb_add. From this context, it looks like > there should not be a tab between int and (*port_multicast_toggle). > > However, when you look at the real file, it becomes clear that it is > actually normal to have a tab between the type and the name of the > function pointer, and that port_mdb_prepare and port_mdb_add are > different to the rest. > > So you patch is O.K.
No worries, thanks for taking a look! -- Florian