> You can define a little helper: > > static u32 aq_hw_read_mpi_state2_addr(struct aq_hw_s *self) > { > return aq_hw_read_reg(self, HW_ATL_FW2X_MPI_STATE2_ADDR); > } > > Then > > readx_poll_timeout(u32 aq_hw_read_mpi_state2_addr, self, > stats_val, orig_stats_val != stats_val & > BIT(CAPS_HI_STATISTICS)); >
[cut] > You see this sort of construct in quite a lot of drivers. Thanks, Andrew, Think that way this'll be the optimal case with best readability. We'll update the patch. Regards, Igor