On Tue, Dec 11, 2018 at 4:49 PM Cong Wang <xiyou.wangc...@gmail.com> wrote: > > On Tue, Dec 11, 2018 at 3:28 PM Saeed Mahameed <sae...@mellanox.com> wrote: > > struct mlx5e_tc_flow_parse_attr { > > - struct ip_tunnel_info tun_info; > > + struct ip_tunnel_info tun_info[MLX5_MAX_FLOW_FWD_VPORTS]; > > struct net_device *filter_dev; > > struct mlx5_flow_spec spec; > > int num_mod_hdr_actions; > > void *mod_hdr_actions; > > - int mirred_ifindex; > > + int mirred_ifindex[MLX5_MAX_FLOW_FWD_VPORTS]; > > }; > > Perhaps 'mirred_ifindexes' (or indices) is more readable here, while you > are on it...
Hi Cong, I actually prefer array names to reflect single entries: mirred_ifindex[vport]; is more readable just like when you give a name to a table column, you don't use the plural form.