On 11/26/18 2:27 PM, Joe Stringer wrote: > @@ -2405,6 +2407,9 @@ enum bpf_func_id { > /* BPF_FUNC_perf_event_output for sk_buff input context. */ > #define BPF_F_CTXLEN_MASK (0xfffffULL << 32) > > +/* BPF_FUNC_sk_lookup_tcp and BPF_FUNC_sk_lookup_udp flags. */ > +#define BPF_F_SK_CURRENT_NS 0x80000000 /* For netns field */ > +
I went down the nsid road because it will be needed for other use cases (e.g., device lookups), and we should have a general API for network namespaces. Given that, I think the _SK should be dropped from the name.