Add section names for BPF_SK_SKB_STREAM_PARSER and
BPF_SK_SKB_STREAM_VERDICT attach types to be able to identify them in
libbpf_attach_type_by_name.

"stream_parser" and "stream_verdict" are used instead of simple "parser"
and "verdict" just to avoid possible confusion in a place where attach
type is used alone (e.g. in bpftool's show sub-commands) since there is
another attach point that can be named as "verdict": BPF_SK_MSG_VERDICT.

Signed-off-by: Andrey Ignatov <r...@fb.com>
---
 tools/lib/bpf/libbpf.c | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/tools/lib/bpf/libbpf.c b/tools/lib/bpf/libbpf.c
index 51edf6cd390e..425d5ca45c97 100644
--- a/tools/lib/bpf/libbpf.c
+++ b/tools/lib/bpf/libbpf.c
@@ -2139,6 +2139,10 @@ static const struct {
                                                BPF_CGROUP_DEVICE),
        BPF_APROG_SEC("sockops",                BPF_PROG_TYPE_SOCK_OPS,
                                                BPF_CGROUP_SOCK_OPS),
+       BPF_APROG_SEC("sk_skb/stream_parser",   BPF_PROG_TYPE_SK_SKB,
+                                               BPF_SK_SKB_STREAM_PARSER),
+       BPF_APROG_SEC("sk_skb/stream_verdict",  BPF_PROG_TYPE_SK_SKB,
+                                               BPF_SK_SKB_STREAM_VERDICT),
        BPF_APROG_COMPAT("sk_skb",              BPF_PROG_TYPE_SK_SKB),
        BPF_APROG_SEC("sk_msg",                 BPF_PROG_TYPE_SK_MSG,
                                                BPF_SK_MSG_VERDICT),
-- 
2.17.1

Reply via email to