The patchset fixes a few code stylistic issues and typos, as well as one detected by sparse semantic checker tool.
No functional changes introduced. Patch 1 & 2 fix coding style bits caught by the checkpatch.pl script Patch 3 fixes an issue with a shadowed variable Patch 4 adds sizeof() operator instead of magic number for buffer length Patch 5 fixes typos in diagnostics messages Patch 6 explicitly sets unsigned char for bitwise operation v2: - submit for net-next - added Reviewed-by tags - use u8* instead of char* as per Davide Caratti suggestion Roman Mashak (6): net sched actions: fix coding style in pedit action net sched actions: fix coding style in pedit headers net sched actions: fix sparse warning net sched actions: use sizeof operator for buffer length net sched actions: fix misleading text strings in pedit action net sched actions: avoid bitwise operation on signed value in pedit include/net/tc_act/tc_pedit.h | 1 + include/uapi/linux/tc_act/tc_pedit.h | 9 ++++++-- net/sched/act_pedit.c | 43 +++++++++++++++++++----------------- 3 files changed, 31 insertions(+), 22 deletions(-) -- 2.7.4