From: Jiri Pirko <j...@mellanox.com> This patchset resolves 2 issues we have right now: 1) There are many netdevices / ports in the system, for port, pf, vf represenatation but the user has no way to see which is which 2) The ndo_get_phys_port_name is implemented in each driver separatelly, which may lead to inconsistent names between drivers.
This patchset introduces port flavours which should address the first problem. In this initial patchset, I focus on DSA and their port flavours. As a follow-up, I plan to add PF and VF representor flavours. However, that needs additional dependencies in drivers (nfp, mlx5). The common phys_port_name generation is used by mlxsw. An example output for mlxsw looks like this: # devlink port ... pci/0000:03:00.0/59: type eth netdev enp3s0np4 flavour physical number 4 pci/0000:03:00.0/61: type eth netdev enp3s0np1 flavour physical number 1 pci/0000:03:00.0/63: type eth netdev enp3s0np2 flavour physical number 2 pci/0000:03:00.0/49: type eth netdev enp3s0np8s0 flavour physical number 8 split_group 8 subport 0 pci/0000:03:00.0/50: type eth netdev enp3s0np8s1 flavour physical number 8 split_group 8 subport 1 pci/0000:03:00.0/51: type eth netdev enp3s0np8s2 flavour physical number 8 split_group 8 subport 2 pci/0000:03:00.0/52: type eth netdev enp3s0np8s3 flavour physical number 8 split_group 8 subport 3 As you can see, the netdev names are generated according to the flavour and port number. In case the port is split, the split subnumber is also included. An example output for dsa_loop testing module looks like this: # devlink port mdio_bus/fixed-0:1f/0: type eth netdev lan1 flavour physical number 0 mdio_bus/fixed-0:1f/1: type eth netdev lan2 flavour physical number 1 mdio_bus/fixed-0:1f/2: type eth netdev lan3 flavour physical number 2 mdio_bus/fixed-0:1f/3: type eth netdev lan4 flavour physical number 3 mdio_bus/fixed-0:1f/4: type notset mdio_bus/fixed-0:1f/5: type notset flavour cpu number 5 mdio_bus/fixed-0:1f/6: type notset mdio_bus/fixed-0:1f/7: type notset mdio_bus/fixed-0:1f/8: type notset mdio_bus/fixed-0:1f/9: type notset mdio_bus/fixed-0:1f/10: type notset mdio_bus/fixed-0:1f/11: type notset --- RFC->v1: -removed nfp patches, removed DSA patch that used name generation helper -patch 1: - Reduced the nfp change just to simply use newly created attr_set func -patch 2: - rebased - removed pf/vf reps flavours -patch 3: - rebased -patch 4: - added missing break pointed out by Andrew Jiri Pirko (5): devlink: introduce devlink_port_attrs_set devlink: extend attrs_set for setting port flavours devlink: introduce a helper to generate physical port names dsa: set devlink port attrs for dsa ports mlxsw: use devlink helper to generate physical port name drivers/net/ethernet/mellanox/mlxsw/core.c | 18 ++++- drivers/net/ethernet/mellanox/mlxsw/core.h | 5 +- drivers/net/ethernet/mellanox/mlxsw/spectrum.c | 21 ++---- drivers/net/ethernet/mellanox/mlxsw/switchx2.c | 11 ++- drivers/net/ethernet/netronome/nfp/nfp_devlink.c | 5 +- include/net/devlink.h | 32 +++++++-- include/uapi/linux/devlink.h | 14 ++++ net/core/devlink.c | 86 +++++++++++++++++++++--- net/dsa/dsa2.c | 24 +++++++ 9 files changed, 170 insertions(+), 46 deletions(-) -- 2.14.3