On Wed, 24 Jan 2018 09:52:16 +0100, Jiri Pirko wrote: > >@@ -606,9 +606,9 @@ struct tc_cls_common_offload { > > }; > > > > static inline void > >-tc_cls_common_offload_init(struct tc_cls_common_offload *cls_common, > >- const struct tcf_proto *tp, > >- struct netlink_ext_ack *extack) > >+tc_cls_common_offload_init__(struct tc_cls_common_offload *cls_common, > >+ const struct tcf_proto *tp, > >+ struct netlink_ext_ack *extack) > > This is really confusing. You do duplication and this odd function > naming only to remove it at the end of the patchset. > But the only goal is to add flags arg and tc_skip_sw check. > > So just add the arg and check and change all the calls to this finction > to pass the flags arg. You will reduce like 8 patches into one that > is well-readable.
I'm trying to keep functional and non-functional changes separate. I talked to Simon and he also prefers to keep things separate. Now classifier maintainers can look at their classifier easily without drowning in a soup of tens of almost-identical patch hunks. Look at the u32 classifier where I have to save the flags. It would be hard to notice that in 20-hunk patch. Does anyone else have a preference? It's easy enough to squash the patches...