Hi Dave, On Mon, Sep 18, 2017 at 09:19:08PM -0700, David Miller wrote:
> > +static inline u32 ipv6_hashfn(const struct in6_addr *a) > > +{ > > + return __ipv6_addr_jhash(a, gtp_h_initval); > > +} > > I know you are just following the pattern of the existing "ipv4_hashfn()" here > but this kind of stuff is not very global namespace friendly. Even simply > adding a "gtp_" prefix to these hash functions would be a lot better. I would agree if this was an inline function defined in a header file or a non-static function. But where is the global namespace concern in case of static inline functions defined and used in the same .c file? If it makes you happy, I'm all for adding the prefix - I just would like to understand the rationale better, thanks :) Regards, Harald -- - Harald Welte <lafo...@gnumonks.org> http://laforge.gnumonks.org/ ============================================================================ "Privacy in residential applications is a desirable marketing option." (ETSI EN 300 175-7 Ch. A6)