On Tue, Aug 01, 2017 at 02:31:44PM +0200, Egil Hjelmeland wrote: > On 01. aug. 2017 13:49, Juergen Borleis wrote: > >Hi Egil, > > > >On Tuesday 01 August 2017 13:14:38 Egil Hjelmeland wrote: > >>Will be used instead of '3' in upcomming patches. > >> > >> > >>+#define LAN9303_NUM_PORTS 3 > >>+ > > > >Maybe we should put this macro into a shared location because > >in "net/dsa/tag_lan9303.c" there is already a "#define LAN9303_MAX_PORTS > >3". > > > >jb > > > > Is there any suitable shared location for such driver specific > definitions? > I could change the name to LAN9303_MAX_PORTS so it the same. > Rhymes better with DSA_MAX_PORTS too.
Hi Egil, Juergen The other tag drivers do: if (source_port >= ds->num_ports || !ds->ports[source_port].netdev) return NULL; or just if (!ds->ports[port].netdev) return NULL; The first version is the safest, since a malicious switch could return port 42, and you are accessing way off the end of ds->ports[]. It does however require you call dsa_switch_alloc() with the correct number of ports. Andrew