On Tue, May 16, 2017 at 2:00 PM, Jiri Pirko <j...@resnulli.us> wrote: > Tue, May 16, 2017 at 10:25:35PM CEST, xiyou.wangc...@gmail.com wrote: >>On Tue, May 16, 2017 at 10:27 AM, Jiri Pirko <j...@resnulli.us> wrote: >>> From: Jiri Pirko <j...@mellanox.com> >>> >>> Move tc_classify function to cls_api.c where it belongs, rename it to >>> fit the namespace. >>> >> >>It is not a pure move, you silently remove the CONFIG_NET_CLS_ACT >>macros in tc_classify(). Probably not buggy, just redundancy when >>actions are not compiled. > > Plese see include/net/pkt_cls.h in this patch. > > If CONFIG_NET_CLS_ACT is not defined, there is a stub there.
I am sure it is not NET_CLS_ACT: #ifdef CONFIG_NET_CLS void tcf_destroy_chain(struct tcf_proto __rcu **fl); +int tcf_classify(struct sk_buff *skb, const struct tcf_proto *tp, + struct tcf_result *res, bool compat_mode); + #else static inline void tcf_destroy_chain(struct tcf_proto __rcu **fl) { } + +static inline int tcf_classify(struct sk_buff *skb, const struct tcf_proto *tp, + struct tcf_result *res, bool compat_mode) +{ + return TC_ACT_UNSPEC; +} #endif